Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Yesterday I performed a Nandroid Backup on my phone, because right after I knew I was going to wipe the phone and cache and remount Cyanogenmod on my Galaxy Nexus to hopefully solve another issue I had.

However, I guess when you do a new fresh mount CM recreates the 0 (profile) directory on the internal memory. So I ended up having to move the folders that contained the backup up one directory level.

The problem I have now is that with the latest backup I am running dangerously low on storage space, so I can't restore all my apps and data and therefore I need to delete an old backup (I have 3 but need only 2). I can't delete the folder using Astro or file manager even when giving them root access, and I thought if moving it to the same location as before CWM would be able to see it and delete, but it just says can't find any backups.

Is there a way to fix it so CWM can see it and I can delete?

The files are currently in the path /storage/emulated/0/clockworkmod/backup

share|improve this question
    
Have you tried looking for these directories while booted in Recovery mode? –  Chahk Apr 4 '13 at 18:47

2 Answers 2

ClockworkMod needs to be updated to properly understand Android 4.2's new filesystem structure so it can see its previous backups.

Technically, everything stored on the sdcard is actually stored under /data/media, however Android uses bind to essentially make a really fancy shortcut to various other places. This includes /storage/emulated/ and /sdcard.

As for deleting, without knowing the errors you were running into, it limits my options on recommendations. But you can use adb to delete files (with the code below, replace "old-backup" with the folder name containing the backup you want to remove).

adb shell
su
rm -rf /data/media/0/clockworkmod/backup/old-backup
share|improve this answer

You can fix it by symlink.

1) remove clockwork dir "rm -rf /data/media/clockworkmod"

2) switch to directory "cd /data/media"

3) create a symbolic link "ln -s /data/media/0/clockworkmod clockworkmod"

that should do it

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.