Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a Samsung Galaxy 3 (GT-i5801) Android phone. Currently, my phone is not being detected by my PC. Initially, when I purchased this phone, I was developing applications and I was able to run the applications on my phone. I have purchased a new cable as I thought the data cable may have been damaged, but that did not solve the issue.

What can be the possible solutions or what do I need to check for in order to connect my Samsung Galaxy 3 to my PC by using a data/USB cable?

I have Windows XP installed on my Dell Inspiron laptop.

share|improve this question
    
there is no need for the exclamation marks, imo. –  Louis Rhys Jan 3 '11 at 6:19
    
Can you tell us what was the message or any other information? –  Louis Rhys Jan 3 '11 at 6:19
    
@Louis Rhys usb device not recognized message is being coming up when i try to connect !! I think i am trying to connect with USB cable so no need to install driver –  Paresh Mayani Jan 3 '11 at 6:43
    
I have similar problem with Samsung Galaxy 3, i5801. Initially mount dialog was appearing but now it is not. it just charge mobile. Do that dialog requires any specific service or program, which might have be uninstalled accidently? In settings-about phone-usb settings- mass storage option is enabled, also tried with ask on connection but no luck. What could be the problem? Thanks in advance. –  JRC Jan 22 '11 at 7:10
add comment

5 Answers

Per userguide after you connected the USB cable on Mass Storage mode, you need to go to the shortcut/notification/USB cable connected then mount.

share|improve this answer
    
Ya it is, but before it was raising when i purchased the phone, but now no such notification comes , just battery is recharging –  Paresh Mayani Jan 3 '11 at 11:52
add comment
  1. Make sure your device is not connected to your PC.
  2. Uninstall any drivers you currently have installed for it.
  3. Reboot your computer.
  4. Install the appropriate drivers from this XDA post (supports more than Galaxy S) http://forum.xda-developers.com/showpost.php?p=7238660&postcount=1
  5. Install Kies from Samsung.com's Galaxy 3 page http://www.samsung.com/uk/support/detail/supportPrdDetail.do?menu=SP01&prd_ia_cd=23020100&prd_mdl_cd=GT-I5800DKAXEU&prd_mdl_name=GT-I5800
  6. Connect your device to your PC.
share|improve this answer
    
thanx for the support, but as i am connecting Mobile with PC by using USB Cable, i haven't install any driver for the same. And ya, i have installed kies from the CD came with the samsung-galaxy-3 purchased box –  Paresh Mayani Jan 4 '11 at 5:21
    
As you have mentioned link for installing driver, it is for Samsung Galaxy S , not for Galaxy 3, check it: drivers.softpedia.com/get/MOBILES/Samsung/… , what should i do ?? –  Paresh Mayani Jan 4 '11 at 5:22
    
I recommend uninstalling the version of Kies that came on your CD, since it is likely outdated, and using the version on Samsung's download page. And as I mentioned in my post, the drivers actually support many Samsung devices and not just the Galaxy S, so don't worry about that. –  Matthew Read Jan 4 '11 at 5:49
add comment

If you were previously developing on your PC, do you have USB Debugging enabled on your phone? That uses a whole different set of drivers than the normal USB drivers, these drivers are available as part of the Android SDK download.

To check if you have USB Debugging enabled, go into Settings -> Applications -> Development -> USB Debugging and take the tick out of the USB Debugging box.

If you turn off USB Debugging, then it should be able to connect to your PC using the standard USB mass storage device drivers.

share|improve this answer
add comment

I had a similar problem when I still had my PALM synchronization software installed. For some reason or another, it used COMM port 4 for it's communication ( don't know why but it did ), and that conflicted ( probably behind the scenes ) with the communication with my Galaxy S.

Once I uninstalled the PALM synchronization software, the connection went fine.

So please check if on your pc some sort of other communication device is installed.

share|improve this answer
add comment
up vote 13 down vote accepted

After searching for a long time and trying a lot, I found a solution:

Resolution

  1. Unplug the USB cable
  2. On the cell phone, dial the number *#7284#. Once the last # is hit, the PhoneUtil application is launched. Choose USB -> Modem and then USB -> PDA mode. The good mode should be PDA. Even if the mode is PDA, switch to Modem and then back to PDA.

    1. Also choose UART -> PDA and then UART -> MODEM mode. The good mode should be MODEM for UART. Even if the mode is MODEM, switch to PDA and then back to MODEM(UART).
  3. Plug in the USB cable.

Note:

This is not only for Samsung Galaxy 3 - Android phone, but it is also used to repair the USB connection for any Samsung Android phone.

share|improve this answer
2  
Many thanks..... –  mihirpmehta Feb 14 '11 at 14:09
3  
A thousand Thanks to Paresh Mayani for the *#7284# tip. USB connection stopped working on my new Galaxy 3 and all Samsung Customer Support suggested was to do a factory reset. I expect that would have solved the problem, but at the expense of losing all my personal settings. So thumbs up for Paresh and thumbs down for Samsung Customer Support! –  user3020 Feb 19 '11 at 15:47
1  
@Michael Thanx for the kind words, i was in same situation as you are, later on i found this solution so i shared it here. Samsung Customer Support had told me for the Factory Reset, what a majak they had done!! They should have atleast know about this *#7284# –  Paresh Mayani Feb 21 '11 at 6:02
    
@PareshMayani thanks a ton!!! –  Kumar Jan 1 '12 at 7:56
    
I am having same problem again but this time this solution doesnt work ... any other idea ??? –  mihirpmehta Apr 2 '12 at 6:42
add comment

protected by Al E. Apr 11 '11 at 14:11

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.