Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Okay, so I already ordered a new battery, but in the mean time. Why won't my phone charge?

  1. I have tried every charger/cable in my house and car (over 10 chargers and around 15 cables).
  2. Double checked the setups with my tablet to make sure they work.
  3. Checked battery temp with a WiFi tether app, shows 27-28 degrees centigrade. Moving so I know it works.
  4. Restarted the phone, reseated the battery.
  5. Replaced the battery with a brand new one.
  6. It is even hesitant to charge when the phone is off. It would show initial charge symbol, then go to the charging animation for 5 seconds and restart. This is the only way to get any juice into my phone by the way.

Update:

If I take the battery out while it's on the charger the screen flickers. At this point if I wiggle the cord I can get the flickering to stop, but I can also get the phone to turn off. So, I bet the solder points on the USB are faulty...

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

MicroUSB ports on phones are delicate and can be prone to losing a proper connection to the power on the circuit board if you're not ultra careful about making sure to not stress the connection point (like having the phone plugged in and the cable is taut).

My Wife has already gone through 2 phones and a laptop due to using them while the power plug is stretched and basically over time causing the power connection to come off the circuit board.

This sounds like the issue you're having and the only solutions are if you take the phone apart and re-solder the loose connection (requires ULTRA fine soldering skills) or take it in for repair and they'll likely have to replace the mainboard.

share|improve this answer
    
I already tried the soldering method with my brick of an iron, so I bought a new USB board a few days ago. I'll keep you posted. –  Eric Fossum Jun 18 '13 at 17:07
    
Yep, after ordering the wrong one I got the correct one before the weekend and it's been working ever since! –  Eric Fossum Jun 24 '13 at 15:19
    
That's great, I'm glad you're able to fix the issue! –  Namuna Jun 24 '13 at 16:11
add comment

Open your car charger and at the back of the USB socket solder together the two middle contacts. These are the D- and D+ signals. Most Galaxy phones don't like an open circuit there, so now you have made a nice loop. Info: http://en.wikipedia.org/wiki/Universal_Serial_Bus

share|improve this answer
    
But it happens with all chargers... including my computer. Leading me to believe that it is a phone side issue. –  Eric Fossum Apr 16 '13 at 15:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.