Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I moved the question from http://stackoverflow.com/q/15872848/1665807

I have a rooted Huawei u8825d phone.I want to know if there were no apk files in "/system/app/" folder.

So,I moved these apk files from /system/app/ to internal sd-card.When I tried to reboot the phone,it didn't succeed.I hanged up with a white screen.

Then I tried to push the apk files from the internal sd-card into the /system/app/ folder by using "adb".

D:\MTH\update>adb devices

List of devices attached

78F5FD6420D5 device

D:\MTH\update>adb remount

remount failed: Operation not permitted

Then,in another way,

D:\MTH\update>adb shell mount -o remount,rw -t yaffs2 /dev/block/mtdblock3 /system

mount: Operation not permitted

This is another way.

D:\MTH\update>adb shell

shell@android:/ $ su

su

Segmentation fault

139|shell@android:/ $
share|improve this question
1  
Bad luck. Without the SuperUser/SuperSU app installed, you can hardly su -- and since you removed all system apps from /system/apps, there is none left. This means you're in a "doom loop": in order to get your files back to /system, you need to remount /system. To do that, you need to su, for which you need the files in /system/apps... I'd say you probably will end up flashing your ROM again. –  Izzy Apr 9 '13 at 7:55
add comment

1 Answer 1

up vote 0 down vote accepted

Root access or SuperUser is an apk that resides in /system/app. If you remove it with the rest of the apps, you lose root. As a possible workaround, you can try to run:

> adb root
> adb shell

And see if the shell that adb opens is $ (normal user) or # (root). If you're logged as a normal user, I'm afraid you will need to reinstall root in your phone.

Also, /system/app is like C:\Windows or /bin (in Linux), if you remove the files there, don't expect the device to run, as it won't have the necessary files to do so.

share|improve this answer
    
As I wrote above: with no SuperUser/SuperSU running, John will most likely end up having to re-flash. Though the su itself in in a different location (/system/bin or /system/xbin), it usually also needs SuperUser/SuperSU to get a root prompt. And the latter he just successfully removed. One thing he could try is creating a suitable update.zip to be flashed from recovery. –  Izzy Apr 9 '13 at 8:01
    
thanks.I've flashed ROM.Everything's fine now :-) –  johnkarka Apr 11 '13 at 1:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.