Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

After about 5-10 minutes of not using the app (i.e., not sending messages), my Google Talk connection drops and does not reconnect till I play with the app a bit. How can I prevent this from happening?

Theoretically it could be a WiFi timeout issue, or related, but I tried the following:

  1. Using RyanZA's OCLF app to set the timeout to an hour.
  2. In Settings -> Wireless and network -> WiFi settings -> Advanced, setting WiFi sleep policy to Never.
  3. Editing the settings database directly to set the WiFi sleep policy to Never.

As well, I still receive emails and the like over WiFi while the screen is locked. I don't have a data plan (there's not even a SIM card in the phone right now), so it seems like WiFi stays connected and is otherwise working.

That said, I do have problems with WiFi occassionally failing to work; see How can I prevent my Wi-Fi connection from glitching? The answer to that question has seemingly fixed the problem with Wi-Fi being glitchy, but it doesn't prevent it from sleeping while the screen is off, so I think something else is wrong. I'm not sure to what extent it affects this GTalk issue.

This has happened in every ROM I've used. Another Jabber client that does not suffer this issue would be OK, but ideally I'd like to fix GTalk. Meebo and eBuddy suffer the same or similar problems.

  • Device: Samsung Galaxy S Vibrant SGH-T959
  • OS Version: 2.2 (Froyo)
  • ROM: Bionix NextGen v1 (TouchWiz version)
share|improve this question
    
Are you sure that's a wifi related problem? There is a issue open at android projet in code.google.com. Maybe all the people with this problem should star the problem there. Note @Matthew-Read If this is also your problem you had better to edit your question to be more precise. Who is reading your question can easily think this is an issue only with WIFI while the problem is more general. Unfortunately in this site I have not enough reputation to comment on questions so I can just post an answer. If you just delete it (like my previous –  karlacio Dec 6 '11 at 17:30
    
@karlacio The question says "Theoretically it could be a WiFi timeout issue, or related, but [...] it seems like WiFi stays connected and is otherwise working." So no, I'm not sure it's a Wi-Fi issue, and neither should anyone who reads this. –  Matthew Read Dec 6 '11 at 17:56
add comment

5 Answers

Clearing the data on apps is a good way to "fix" misbehaving apps. I've noticed sometimes apps go haywire and stop working properly. Sometimes rebooting fixes it.

From my time in the modding community loading custom ROMS (CyanogenMod) there was a time when Google Talk on some of the ROMS wasn't working correctly. I don't know what fixed it. At that time, having to constantly start GTalk was the only way to keep all your Google stuff synced.

I have Wi-Fi set not to sleep but notice I've never been able to completely prevent it from sleeping after longer periods of time. That glitching may be screwing up your GTalk.

My best guess at this poing (sorry it's just a SWAG) is to remove the GTalk app completely, wipe your Dalvik, and reinstall GTalk. You can use Titanium Backup to remove the app or the SDK bridge. Make sure you have the correct Gtalk APK before removing the one you have. If all else fails, reload your ROM.

share|improve this answer
    
I remember when GTalk and the Framework had those issues as well. I reload my ROM pretty regularly due to experimentation but I'll try the removing/reinstalling the app part. –  Matthew Read Dec 3 '11 at 20:28
add comment

Well, if you need google talk for talking to people you could just use a third part im client like xabber or imo. The thing is, android routinely kills processes if they're not active, and these apps work around that by placing a persistent notification in the status bar, which prevents android from killing them (don't ask me why) If you gtalk because google uses it for syncing, you could use a widget that requests sync when you click it. Not really a solution, but good enough for me.

share|improve this answer
    
Hmm, one or both of Meebo and eBuddy also have a persistent notification with no better results. I may try these anyways though, thanks. –  Matthew Read Dec 3 '11 at 20:24
add comment

As far as I can tell, the only way to resolve this is by "hacking" your phone. This XDA post shows you how to change the length of time. I'm guessing putting "-1" for the length of time would cause it to not turn off, but haven't tested it myself.

share|improve this answer
    
I believe this is the same hack used in OCLF -- it does seem to work as far as the WiFi goes, but GTalk still disconnects. Thanks though. (Odd that the post is for the opposite issue of wanting to shut off the Wi-Fi :P) –  Matthew Read Jan 24 '11 at 23:04
add comment

I'd use default settings for the Wifi time out since it adds significant drain to the battery. I have a Motorola Droid and try to exclusively use 3g and use these settings.

  1. Open Google Talk.
  2. Press Menu button.
  3. Settings.
  4. Check the following.
    1. Automatically sign in
    2. Mobile indicator
    3. Automatic away-status.

I stay signed in and I go idle when the phone is sleeping.

share|improve this answer
    
My battery life is quite good, I don't have a data plan, and I've tried having auto-away both on and off with no effect. –  Matthew Read Jan 4 '11 at 4:22
add comment

Looks like you have to root your device per the first 2 answers http://forum.xda-developers.com/showthread.php?t=774507

share|improve this answer
2  
This is a duplicate of jeffl8n's answer. –  Matthew Read Nov 28 '11 at 23:00
add comment

protected by Al E. Dec 7 '11 at 4:37

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.