Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

My stock Nexus 4 (4.2.2) is giving me multiple calendar notifications every day. It gives me one notification which is a reminder for a specific upcoming event, and it gives me a second notification which is sort of a general roll-up of upcoming events.

Here's an example of the two notifications:

Screenshot
Screenshot (click image to enlarge)

I rely heavily on the reminder notifications, but I find the rollup to be useless for me. I've verified that both are coming from the Calendars app by long-pressing on the notifications and clicking on App Info.

How do I disable the second "roll-up" calendar notification?

share|improve this question
    
When you click on the "roll-up" calendar notification what app opens? –  ZnewmaN Apr 10 '13 at 17:49
2  
Do you really have "Feed dog" as a calendar event!? :) –  w3d Apr 10 '13 at 19:15
    
@ZnewmaN When I click on the roll-up, I get a dialog filling most of the screen called "Calendar notifications" with a scrollable list of upcoming events. When I click on the reminder, I go directly to the specific event in the calendar app. –  emmby Apr 10 '13 at 20:34
4  
@w3d My dog has no opposable thumbs so he has trouble entering these reminders into his own phone. –  emmby Apr 10 '13 at 20:36
    
@emmby can you post a screenshot of the screen that you get when you click on the rollup notification? –  ZnewmaN Apr 10 '13 at 21:11

4 Answers 4

up vote 5 down vote accepted

I can confirm that this is normal behaviour for the default (blue) Google Calendar on the Nexus 4 - just the 1 app. Having tried a few tests of my own...

Multiple Calendar Notifications

The multiple "roll-up" events appear to be events for which you have already received a notification, but have not explicitly acknowledged or "dismissed" it - in which case the notification remains in the notification area and forms this group when the next notification occurs.

In the screenshot above, a notification has just occurred for "Test3", while notifications have already occurred for "Test1" and "Test2", but I did not acknowledge/dismiss them. I could, for instance, tap on the "roll-up" and dismiss "Test2" - it will then be removed from the notification area.

The only way to stop this roll-up of events is to either:

  • Dismiss the notification as it occurs.

  • Don't set a notification for these events.

share|improve this answer
    
Instead of turning off notifications for events just disable pop-up notifications in the Calendar app (which are what's being queued in the roll-up mentioned by @emmby) here: Settings > General > Notifications and Reminders > Pop-up notification. –  Mr. Buster Jun 21 '13 at 23:09
    
I already have Pop-up notification disabled (which I believe is the default option) and I get the same roll-up of notifications. However, the Pop-up notification is different... you get an obtrusive pop-up when the notification occurs and you seem to get no option but to acknowledge/dismiss it, at which point it is removed automatically from the notification area. So, in fact, enabling pop-up notifications would prevent the roll-up, since you are forced to acknowledge them. –  w3d Jun 21 '13 at 23:52
    
Thanks for the clarification! –  Mr. Buster Jun 21 '13 at 23:58

There are likely two calendar apps on your system. Stock Android includes an app and Google provides one as well, which might be preinstalled on your device, or you may have downloaded it without realizing it. They both look very similar (which is probably why you thought they were the same when you held on them for the App Info screen). Check in your app drawer. The stock Android calendar is a green calendar icon, and the Google one is blue. Then disable notifications for one of them.

You can always click on the roll-up notifications and when that app opens, go into the settings and disable notifications. Then go to your app drawer and check both icons (both are labeled calendar) see which app has notifications disabled. Once you determine what app it is, if it is the Google Calendar, you could just uninstall it, or if it is the built-in one, you can disable it via Settings -> Apps -> All -> Calendar -> Disable.

share|improve this answer
1  
An easy check for your theory would be: follow one of the notifications, and disable notifications for the app turning up as source. Wait for the next event and see if both notifications are gone, or one remained :) –  Izzy Apr 10 '13 at 18:44
    
I also have a stock Nexus 4 (4.2.2) and I only have a blue Google Calendar - there is no (stock) green calendar. The same for my ICS tablet (both the same version). AFAIK the blue Google Calendar in the Play Store is (or at least is now) the stock Android Calendar. If I ever had the green stock calendar on my tablet it has been automatically replaced with the blue one (via the Play Store). –  w3d Apr 10 '13 at 19:13
    
Long-pressing on the notification should give you a link to "App Info", which will at least tell you which app is raising which notification. –  Al E. Apr 10 '13 at 19:29
    
Apparently Google replaced the stock Android calendar app (the green icon), with their proprietary calendar app (the blue icon). They did the same with the browser and put on Chrome. The Google calendar app and Chrome are not part of AOSP, but apparently, Google replaces the stock ones with their versions on newer builds. –  bassmadrigal Apr 10 '13 at 20:07
1  
i verified using App Info that both notifications are coming from the same app. Calendar version 201212060 –  emmby Apr 10 '13 at 20:32

If you use the calendar app that I do (which I believe is the stock Android calendar app that has a pink icon),

  • Click the icon to open the app,
  • Click settings
  • Then mine has a "Set Alerts & Notifications" where I can select from 3 options: (1) Alert, (2) Status Bar Notification, or (3) Off.

I use the stock calendar which uses my Google calendar and I also use Nudnik reminders app. So all three of those apps have settings for notifications that I have to consider.

Hope this helps!

share|improve this answer
    
So to complete your answer: You obviously have turned off notifications and alerts in all calendar apps, and have Nudnik Calendar Reminders deal with them, correct? That would match what I did, just that I've used Calendar Event Reminder (CER). –  Izzy Jun 21 '13 at 23:48

If you are using the BLUE Google calendar and want to stop getting 2 notifications do as I do:

I went into the Stock Android Calendar (Pink) & in Settings checked the Play Notification Sound Box, picked my Notification Sound & then UNCHECKED every other box for these settings.

Then I went to the BLUE Google Calendar & General Settings. In Notifications & Reminders I checked the Notifications Box, picked my sound so that it is the Same one as the Stock Calendar one I chose earlier & decided to check the box to vibrate & I checked Pop-up Box.

Then I UNCHECKED the the MAIN Notifications Box leaving the other boxes checked but greyed out.

If you leave the MAIN Notification Box checked as well you will get 2 pop-ups!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.