Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On the main home screen when I slide between the different pages, a voice says "page 1 of 2" "page 2 of 2" etc. This also happens when my phone is on silent mode and out of driving mode. How can I get rid of it, or at least make it silent while my phone is on the silent mode? Very much appreciated!

share|improve this question
Check to see if TalkBack is enabled under accessibility in the settings menu. – ZnewmaN Apr 18 '13 at 13:02
I can't post an answer yet even though I have a rep of 101. Anyway, I was having the same issue on my S2 - I found it was because I had LastPass installed and turned on under Services. Maybe if any Service (TalkBack, LasPass) is On the S2 talks when you turn pages. Turning both services to off on my S2 stopped the voice prompt. – JLWarlow Dec 31 '14 at 10:13

A bit late I know, but I've just been having a similar problem with a Samsung Galaxy S3 Mini.

This is how I got rid of it. I tried other ways, but found that if I turned the phone on and off again, the speech would come alive again. This was the only way I could kill it off for good.

Go to Settings -> Accessibility -> Text to Speech and there will be a list of current text to speech providers (I had 2, Google and Samsung)

  • Go to Application Manager -> All
  • Find Google Text to Speech and disable it
  • If there is no disable button, you will have to click Uninstall All Updates first, then go back, and the button should now read Disable

You'll want to do the above step for each Text to Speech option you had in your list. I had 2, so I did it again for Samsung TTS.

Now if you go back to Settings -> Accessibility -> Text to Speech there should be nothing left in the list and your home screen will finally be silent. Hooray!

I also have driving mode and TalkBack disabled. I already had them turned off, but they didn't help.

Hope this helps.

share|improve this answer
Excellent answer – adrianos Nov 13 '14 at 16:28

Go to Settings>Voice input and output>Text-to-speech settings and check "Driving mode".

share|improve this answer

protected by Community Feb 14 '14 at 22:24

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.