Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have had this phone for a few months and only now did I try to start using the vibrate function. When I choose "Vibrate" from the drop-down bar it never vibrates when I receive texts though sometimes it works when I use the Facebook messenger app. I went into settings and enabled everything that has the word "Vibrate" in it. Also, my phone is on power-saving mode; does that have any impact?

The vibrate function is supposed to notify you of incoming notifications but by vibrate, yes?

Is it a hardware problem?

OS: 4.1.1 Model: SGH-l747M

share|improve this question

3 Answers 3

up vote 1 down vote accepted

Power saving mode (by default) turns off some vibration, but it should only turn off the "haptic feedback" vibration (vibration when you touch certain UI controls). You can change that by going to Settings, Power saving mode, and unchecking "Turn off haptic feedback". That's the mode I run my SGS3 in all the time.

To get vibration working for text messages, you also need to enable vibration in the settings of the Messaging app itself (I'm not sure which settings you were referring to when you said that you "went into settings and enabled everything that has the word "Vibrate" in it"). To do that, go to the conversation list in the Messaging app (not an individual conversation), hit the menu button, then select Settings. Look for the "Notification Settings" section and check "Vibrate".

To get vibration working for incoming calls, there is a similar setting in the Phone app. Launch the Phone app, make sure you're on the Keypad, Logs, or Favorites tab, tap the menu button, select Call settings. Then select Ringtones and keypad tones and select Incoming call vibration. The Device vibration will let you modify the vibration pattern used (so you can tell an incoming call from a text message / email).

To get to the Phone and Messaging apps: Press the "home" button at the bottom of the phone (the physical button in the middle). That brings you to your home screen. The touch the "Apps" button (it looks like 9 square white dots, and is usually on the lower right of the home screen). That will bring up a list of all applications installed on the phone. Scroll through looking for an app named Messaging (or Phone). The icon for the Messaging app looks like a white envelope with a yellow piece of paper coming out of it. The icon for the Phone app looks like a green square with a white phone receiver on it. Tap the app icon, then follow the instructions for each app above to activate vibration for text messaging and incoming calls.

share|improve this answer
    
My haptic mode has always been off. I was using Facebook as an example to show that the vibrate function works sometimes but my actual concern is getting notified of incoming calls and texts when my phone is in vibrate-only mode. –  verve Apr 19 '13 at 13:00
    
I went into my phone "Settings" to make sure all options that have to do with the vibration mode was on. –  verve Apr 19 '13 at 13:02
    
It's good that you've enabled vibration in the "Settings" app. But it's not enough. You also have to enable it in both the Messaging app and the Phone app. See my answer for instructions, if you need them. –  Trebor Rude Apr 19 '13 at 13:53
    
What exactly is the Messaging app? I'm not interested in getting notifications from Facebook but the text messages I receive directly on my phone. I'm lost. –  verve Apr 19 '13 at 14:35
    
I can't find my Phone app. Where is it and what does it look like? –  verve Apr 19 '13 at 14:37

You can try it in other modes than power saving. To make you phone in Vibrate only mode, hit the volume keys till the volume bars come down and shows the vibrate mode.

Yes when on vibrate mode all notification via WhatsApp or FB messenger will be via vibration only.

share|improve this answer

I was having the same problem with the vibration for my phone even when vibration was turned on for calls/texts/etc until I realized it was because the vibration intensity was turned all the way down. Go to Settings, click on Sound, then click on Vibration Intensity and make sure it's turned up.

share|improve this answer

protected by Community Sep 11 '13 at 16:37

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.