Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Background:

  1. Browsing on Chrome, device suddenly freezes. Hold down power button to turn it off.
  2. Turn it on again. "Galaxy S2 i9100T" logo keeps displaying nothing else happens. Tried rebooting again, same result.
  3. Try to do a factory reset through recovery mode. I notice that the progress bar freezes unlike the resets I've done before. Takes a while. I get a bunch of errors in red with failed to mount on E/ and invalid arguments (this is the best I can recall).
  4. Now when I turn it on the Galaxy S2 logo will blink in 3 second intervals.
  5. Tried using Odin to root it and install fresh firmware (followed this guide). I also used Siyah v5.0.1.tar as directed. Using latest version of Odin.
  6. After clicking start (auto reboot, f. reset time and PDA checked) Odin gets up to NandWrite. A couple of minutes later I get an error message that it failed.
  7. After unplugging my phone will show phone...orange "!"...PC. I can't get into recovery. When I go into Odin mode it detects a custom binary.

I'm afraid that my phone is bricked at this point and I don't want to get myself into further trouble without consulting someone who actually knows there way around these things.

What are my options here?

(I would prefer to keep the stuff on my sD card but if it has to be deleted as a last resort then so be it.)

share|improve this question
    
You could try the heimdall software instead of Odin. –  ce4 Apr 22 '13 at 8:14
    
Did you just remove micro SD card and reboot before doing factory reset? Did you try to boot in safe mode before doing factory reset? tested.com/tech/android/… –  jis May 2 '13 at 13:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.