Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I am trying to apply Jelly Bean firmware update on my Galaxy S2 X, but everytime I try to, Kies dies at 0% of the firmware update, without any error message.

I tried uninstalling and installing Kies again. It is up to date. I also tried running it in Windows 7 mode and XP SP3 mode (I'm on Windows 8 64-bit).

I did a factory reset of my cellphone, and still encounter the problem.

Is there any alternative or way to fix this?

share|improve this question

2 Answers 2

Samsung Kies sucks horribly. The only way I've gotten it to work is to run it in Compatible with Windows XP (Service Pack 3) and running it as a administrator. It should work fine then.

share|improve this answer
up vote 0 down vote accepted

I actualy got it by doing the update from a Windows 7 computer. Kies seems to have difficulties with Windows 8.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.