Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a samsung galaxy s3. It is only 7 months old. Its battery is not getting charged. I have tried to reboot and take the battery out and put it again,it still doesnt get charged. The usb port is not faulty as others phones get charged from it. What should I do?

share|improve this question
add comment

2 Answers 2

I think the USB port of your phone is defective. IMO it's best you get it replaced while warranty is still active(Samsung offers one year warranty)

share|improve this answer
    
This is likely to be the case. To confirm, hook the S3 to your computer and see if it shows up as a device. –  Trebor Rude Apr 24 '13 at 10:24
add comment

Try too clean the plug on your phone with a thin needle or brush. I had the same problem than you did, and clening it up solved the problem

You can have a look there: http://www.youtube.com/watch?v=R6p0Eg-yq3A.

If you to this cautiously with proper tools, there is no risk for you to damage the phone.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.