Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

After much waiting and tribulation, I've finally successfully unlocked tethering and installed Paranoid Android on my Nexus 7 3G device.

In the progress, I had to tell Windows to ignore its default MTP drivers and use Google's debugging own to interface with Android, fastboot and the like. As a result, I now can't go back to accessing the device using MTP from inside Windows itself.

I tried uninstalling all the relevant drivers from Device Management, but now Windows prefers Android ADB Interface to whatever I was using before. I've tried to force the setup of MTP drivers from Device Management, Add legacy hardware, Install the hardware that I manually select from a list, Portable Devices, (Standard MTP Device), MTP USB device. This didn't work ("This device cannot start. (Code 10)").

How can I get file transfer back?

share|improve this question
1  
Which version of PA are you using? For what it's worth I also have a Nexus 7 (Wifi) running PA and also can't enable MTP. –  1990clb Apr 1 at 15:16
    
Does it work with Linux? Linux should always work fully "out of the box" with Androids, so if it has a problem it's the ROM, not your computer/Windows drivers. –  NoBugs Apr 9 at 5:54

1 Answer 1

Try to identify the location of the driver on the system ie, windows/system32 then uninstall the software and the driver from device manager. Once you have done that return to system32 or where ever its located and delete it. Reboot your system and try installing the old drivers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.