Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I am having a large issue with my S3. I bought a brand new S3 from a trusted friend, he explained to me that it was with Bell originally, (original carrier). So when he sold it to me he also said he unlocked it.

When I got home I activated the Sim card with my Carrier wich is Videotron. I started receiving text messages but there was something strange, I was roaming data. Now this is where it gets weird, first off I had a double clock wich said roaming on one side and home on the other. Also on the top it said Rogers wireless.

So I Disable data roaming. But it still seemed to be carrying the signal. When I went in mobile networks and searched for my carrier, all that showed up was Bell, Telus and Rogers. NO videotron?

I called tech support and they have no idea what the problem is, because it's not there signal coverage. So it's pretty easy for me to know the problem is within my unlocked phone -- but I seem to have hit a wall. I really need help and I don't know what to do. Maybe my friend didnt unlock it correctly? If anyone heard of this issue before or has anyways to help me please share.

share|improve this question
    
Please take a look at the configured APNs. An obvious explanation would be if your S3 still uses Bell settings here. If so, verify with your carrier (Videotron) what the APN settings should look like. As for the unlocking: If the device would not be unlocked, your SIM would have been refused completely. So I doubt that's the culprit. –  Izzy Apr 28 '13 at 18:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.