Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Every time I connect my phone to my computer via USB (Huawei U8666E, Android 4.0.3) even after I've disconnected my phone, the following 2 things happen (that I can tell): My ringtone goes back to "Default" (i'm using a custom one which is saved on the SD memory) and my music playlist (the only one i have) goes empty. No music file is missing, they're just removed from the playlist, and they, too, are on my SD memory.

What can i do to fix or circumvent the issue?

Edit: The problem is not that it happens while the phone is hooked on the computer, but that it persists AFTER i disconnect it. In other words, after disconnecting the phone, i have to manually rebuild my playlists and change the ringtone again. Is there a way for me to transfer data between PC and phone without having to "reconfigure" the phone after the process? Or better yet a way to use the USB normally without the "reconfiguring" having to take place?

share|improve this question
1  
Same issue in this place -- unfortunately now answer either... –  Izzy May 1 '13 at 16:25
    
Guy below seems to be up to something, BUT not there yet. –  Thanos Maravel May 1 '13 at 18:34

2 Answers 2

It sounds like your ROM doesn't properly reset settings when the sdcard is re-enabled (since it obviously becomes unavailable to the OS when using USB Mass Storage). Unfortunately, this is likely an issue with your ROM and I don't think there is a likely setting that would fix it.

However, in Android 3.0, Google added MTP (Media Transfer Protocol) support and it has been in all versions since. This allows the sdcard to remain mounted in the Android system while also allowing it to be accessed on the computer. I can't remember the exact layout of ICS, but to be able to change it to MTP from UMS, it is probably pretty close to Settings -> Storage -> Menu -> USB Computer Connection -> enable MTP

share|improve this answer
    
Sadly, no changeable options under the "storage" entry (no menu), only data exposition. Any other ideas where it might be? Also, what is UMS? Not a very technical guy (yet), managed to read the other ones but not this :P –  Thanos Maravel May 1 '13 at 18:27
    
UMS is just the acronym for USB Mass Storage (an acronym within an acronym... gotta love it). But you should have access to a submenu within your storage section. Does your device have a menu key? If it does, press that, if not, there should be a 3 dot "action overflow" menu button somewhere on the screen. If your manufacturer for some strange reason removed that, you might be able to get MTP working with Multi-Mount (I don't think root is required for MTP) –  bassmadrigal May 1 '13 at 19:15
    
UMS stands for USB Mass Storage, where the mounting device (here: computer) gets physical access to the mounted storage (here: SDCard), while with MTP only logical access is given. –  Izzy May 1 '13 at 19:15
    
Sadly, my options are "Software update", a detailed report on SD and Internal memory allocation, and complete erasure of either. The menu button, although available, does nothing in this screen. I will investigate the aplication you linked. Anything else? –  Thanos Maravel May 1 '13 at 19:21
    
No juice with the app. It crashes as soon as i connect the cable, leaving me connected via Mass Storage and causing the typical aftereffects :/ Any other ideas on turning on MTP? –  Thanos Maravel May 1 '13 at 20:12

In Settings > Storage > press the menu key > USB connection > MTP connection.

share|improve this answer

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.