Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Sometimes after I shut off Wi-Fi using the button inside the notification bar drop-down, I can't turn it back on with that button. Hitting the button does nothing, it's not even highlighted. When I go into Settings -> Wireless and network -> Wi-Fi settings the status under "Wi-Fi" shows Error. If I click "Wi-Fi" to turn it on from here, it usually turns on without any problems. Occassionally I have to reboot to fix it.

Is there a fix I can use to make the TouchWiz Wi-Fi button work the same as enabling/disabling the Wi-Fi in Settings? Or, ideally, is there some way I can prevent the Wi-Fi from getting into an error state when I turn it off and back on?

I have a Galaxy S Vibrant running 2.2, but this has been reported on other Samsung phones as well (example).

share|improve this question
    
Never had any problem with turning Wifi on and off using that button, I use it at least twice a day most days. I am running the official Samsung OS release of 2.2 rather than a ROM. –  GAThrawn Jan 10 '11 at 18:26
    
This is also happening to me but: first once I get the error I can't turn on wifi until reboot, never. And second: I'd tried turning on wifi ONLY from settings, not from widget or notifications bar and it also breaks! –  Diego Aug 10 '11 at 19:39
    
@Matthew -- I have same symptoms as you do, same phone, too; I don't recall ever being forced to reboot, though. Going into Settings almost always works for me on the first shot (90% of the time). If it doesn't work the first time, a second shot in the Settings seems to always work. –  Joe Casadonte Nov 29 '11 at 20:53
add comment

6 Answers 6

I've had the same thing happen to me on my LG G2X running CyanogenMod. So I don't think it's related to your specific device or software. Moderate success has been reported using the "FXR WiFi Fix And Rescue" app, and it's been tested on the Vibrant. You can also try WiFi Fixer.

share|improve this answer
    
I will try them out, thank you. –  Matthew Read Nov 29 '11 at 21:02
add comment

I've had this happen to me 1 time. I don't think there's anything you can do about it except use the settings. Once you change it in settings, does it work again for you? I did the same in settings, but don't know if I rebooted after the fact.

This could also be something in Nero v3 that is causing it.

share|improve this answer
    
It does work again afterward, until it occurs again. It does seem to be unrelated to my particular ROM though, although it occurs less often on Bionix. –  Matthew Read Jan 7 '11 at 23:50
add comment

I had all sorts of weird problems like this when using TouchWiz on my Droid Charge. No problems after installing LauncherPro. Perhaps its an odd bug in the TouchWiz code.

share|improve this answer
1  
Hmm. It seems unlikely that this would fix the case where it can't even be changed in Settings and I need to reboot, but I suppose I should try it! –  Matthew Read Nov 28 '11 at 23:05
add comment

I have had the same annoying problem. I've found that the following sequence consistently restores my wifi to a working state:

From the problematic "Turning on...." message in Settings -> Wifi: 1. Press-and-hold the Home button, to activate the Task Manager. 2. End any/all apps that are listed (often, these are recently opened, but not currently active, apps) 3. Press the "Back" button. This should return you to the Settings -> Wifi screen. The wifi state should have changed and should now read "Error". 4. Click the check box to turn on the wifi. If successful, the device should connect almost immediately to any known access points.

Not a true fix, but definitely quicker than power-cycling the device.

Hope this helps someone.

share|improve this answer
add comment

I finally found an easy workaround that does NOT require me to restart my phone. (After one year of getting annoyed with this Wi-Fi "error" message on a crappy Samsung GT-I5500, running android 2.2)

  1. In the Wi-Fi settings screen (where you toggle Wi-Fi on/off), tap your phone's Menu button to open a context menu at the bottom of the screen.
  2. Click 'Advanced'
  3. Switch the Wi-Fi sleep policy from 'When screen turns off' to 'Never'. (I think switching it from any setting to any other will actually work)

I've been trying this out for a couple of weeks, and turning on the Wi-Fi after doing the above has so far always worked. I've also changed to setting back to 'When screen turns off'. Perhaps leaving it a 'never' will prevent the error from turning up, but I'd like the sleep policy to save some battery.

share|improve this answer
    
Unfortunately I always had it set to Never! –  Matthew Read Nov 3 '13 at 18:49
    
@Matthew: Good to know. However, I am thinking that just switching the setting might solve fix the issue without requireing a restart. Don't know if you can still test this (more than 2 years after your original post) –  Rabarberski Nov 4 '13 at 10:49
add comment

My belief is that this is a bug in google backing up remembered access points and unnecessarily restoring them. Try long clicking each remembered access point and select forget, next setup each access point password as you reconnect to each (or manually if you remember the ssid).

share|improve this answer
    
By "Google" do you mean their online data backup feature? I have that disabled. –  Matthew Read Nov 29 '11 at 7:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.