Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to disable the airplane mode in order to return to normal state. After a long press on power button, I do have the "device options", however nothing happens when I press Airplane mode (airplane mode enable). I am stuck in airplane mode

Have you experience this? Is it a known bug? How can I disable airplane mode.

share|improve this question
1  
Which ROM you are using? Did you tried Basic fix "Restartng your Device"? – Akhil May 20 '13 at 6:51
    
I had this problem, check inflightmagazine.co/?p=351 – Mohamed Khamis Oct 21 '13 at 16:09
    
I think this device is not the galaxy-s, but the galaxy-sl. if so the tagging should be adjusted. gsmarena.com/samsung_i9003_galaxy_sl-3761.php – Mindwin Sep 30 '14 at 19:31

Go to SETTINGS > WIRELESS AND NETWORKS and uncheck AEROPLANE MODE from there.

If that doesn't work, remove the battery and SIM card, wait 1 minute and re-insert SIM + battery and restart.

share|improve this answer

Run this on adb. This will toggle Airplane Mode.

adb shell am start -a android.settings.AIRPLANE_MODE_SETTINGS
adb shell input keyevent 19 ; sleep 0.1; adb shell input keyevent 23; sleep 0.3; adb shell input keyevent 4;
echo "Toggled airplane mode";

[Source]

share|improve this answer

protected by Community Oct 19 '13 at 16:21

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.