Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

When I have my samsung galaxy 9000 (with Android 2.2) on a flat surface (table) and start an application, then the application is shown in landscape mode, even when the start/home screen was in portrait mode.

This does not happen when I hold the phone in my hands.

Is there a way to disable this behavior?

Update: I think I got something wrong: the home screen is never rotated, so the problem is simply that the galaxy thinks it is in landscape-mode when it is lying flat.

share|improve this question
1  
Maybe your table isn't perfectly perpendicular to all rays extending from the center of the Earth's mass that pass through it. ;) –  Matthew Read Jan 12 '11 at 16:50
    
@Matthew Read: I don't care! It's called **smart**phone so I want it to behave smart ;-) –  M4N Jan 13 '11 at 19:13
    
You want your phone to go into landscape when you intentionally angle it, right? How is your phone supposed to know whether it was angled intentionally or not? If calibration doesn't work, your table isn't level. How is this a problem anyways? You're standing, leaning over the table, looking directly down at your phone, and unable to turn it 90 degrees or rotate yourself 90 degrees? Weird. –  Matthew Read Jan 13 '11 at 19:35
    
@Matthew: when it's level, I want it to be in portrait mode (not landscape). Why: the main screen/apps-menu is always shown in portrait mode, but as soon as I start an app, it switches to landscape. Of course I can rotate it, or tilt it to switch to portrait mode, but it's annoying. –  M4N Jan 13 '11 at 19:58
add comment

2 Answers 2

You can disable auto rotation all together , the phone stays in portrait mode than, but won't switch to landscape when you are holding it, either.

If you would like to do this anyway: slide down the notifiction bar at the top and disable the 'auto rotation' option ( on my phone this is the icon to the right).

share|improve this answer
    
Thanks, I know that option, but it's not what I want. I'd like apps to be started in the same orientation as the home screen is currently being displayed. –  M4N Jan 12 '11 at 12:13
add comment

Try recalibrating the orientation sensor from Settings -> Display -> Horizontal calibration. My phone does this too occasionally, since when the phone is lying flat, the difference between portrait/landscape is very small in the sensors.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.