Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Whenever on of my contacts ring my phone, it does not display the caller ID and simply marks them as "Unknown".

I don't mean saying the contacts name out loud either- I just mean the caller ID isn't displayed on the screen for incoming calls. Even when the contacts are saved into my phone.

Please help! It's driving me mad and leading me to avoid all phone calls at the moment.

share|improve this question
    
What version of Android you got on that there device? –  Al E. Jun 6 '13 at 15:52
    
And are you sure they do not suppress their numbers? Try calling yourself from a phone you know it presents its number. Is it shown? Are only your contacts affected, or does no number ever show up on incoming calls? –  Izzy Jun 6 '13 at 18:13
    
How are your contacts stored? For instance, i know if you store your contacts with a period (000.000.0000) the SMS app will not allow you to send a text to that number. –  William Jun 6 '13 at 19:46
    
I have no idea what version of android, just the one that came with it? Sorry- as you can tell I am not really tech savvy. I'm sure they don't have their numbers blocked because whenever they called I would asked them why their numbers were on private and after checked I was told that they are not. They are just stored on the sim card without a period between the numbers. –  KaylaAnne Jun 7 '13 at 4:17
    
You can find the Android version going to Settings->About on your Android device. –  Izzy Jun 11 '13 at 10:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.