Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Ever since the new update of Google Play app, I couldn't get the apps to automatically (in background) update. But instead, they only update, when I open the Google Play app a few times

I have auto-update and notificatoins checked. I have auto-update apps ofer WiFi only set.

I have JB 4.1.2 and Galaxy S3 GT-I9300.

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

I think any auto-update/notification settings relate to apps installed via the Play Store, not the Play Store itself. That's updated occasionally by Google. You could try and force an update, if you're convinced one is available and that you're missing it, by going into the Application Manager and uninstalling updates for Play Store, then clear data, and clear cache, then running the app again and seeing if it forces the download of a newer version.

(Incidentally, I have the S3 too, and am currently on v4.1.10 of the Play store. Which version are you on?)

share|improve this answer
    
I can confirm this: the auto-update setting in the Play app only refers to auto-updating apps you install via it, not to the Play app itself. Back in the days when the latter was still named "Market", there was a separate "market-updater" app responsible for that; I assume this part is now covered by the "Google Play Services" app. –  Izzy Jun 7 '13 at 11:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.