Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I've updated cm from 10.0.0 to 10.1.2, and after updating the gapps too, several things are broken, including Gmail and Drive.

Now, Google Play lists them at "updatable", but it is broken and refuses to update any app, reporting Error retrieving information from server. [RPC:S-5:AEC-0].

Some google services apparently work (Contacts, Calendar), so I guess it's no login problem.

I've tried wiping data of a few related apps, but it didn't help.

share|improve this question
add comment

2 Answers 2

up vote 3 down vote accepted

The error [RPC:S-5:AEC-0] is down to having to remove your google account and re-add it again.

If your account is primary google account, the only way you can remove it is to factory reset and re-install everything! That is the only known cure and quoted by Google themselves! Do not think they are taking it seriously enough. It broke on a previous update to Google Play Store about two months ago.

I get that too, if keep trying over a few minutes, it will eventually update, not successfully though.

I do think its more of an issue on the Google system itself in conjunction with Play store app.

It's not just confined to AOSP JB/ICS or CyanogenMod, I get in on Gingerbread too.

PS: As matter of curiousity - do you have Google 2-step account verification active on your account?

share|improve this answer
    
Yes I do have 2-step verification active. –  Lohoris Jul 19 '13 at 7:57
    
BTW no, even switching account still gives the same error. –  Lohoris Jul 19 '13 at 8:02
    
I wiped and re-installed, couldn't be bothered to keep waiting for magic. –  Lohoris Jul 19 '13 at 10:55
add comment

You seem to have found your answer on your other forum:

  • You need to flash the Android 4.2 gapps from http://goo.im/gapps
  • reinstall all apps that are having problems

from: http://forum.cyanogenmod.com/topic/75232-upgrade-to-1012-messed-up-many-things/

share|improve this answer
    
Didn't work, sorry. –  Lohoris Jul 19 '13 at 7:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.