Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have set up wifi, I installed HTTP proxy and configured it, but where I put the proxy authentication credentials?

share|improve this question
up vote 3 down vote accepted

According to this, you need an external app and you need to root the phone.

Some other solutions shared in a Google Code issue thread.

Update:

Using Gesture Search, I entered "proxy" and got to the Proxy settings on my Droid. Don't know how to get there otherwise, and don't know if it actually works, but there you go. (Someone else mentioned it in that Google thread.)

share|improve this answer

My Samsung Galaxy S II has proxy settings enabled under

Settings > Wireless & Network > Wifi settings > Advanced

I can set a proxy address and a port number.

The proxy I'm sitting behind requires authentication tho and I'm having trouble finding these settings.

share|improve this answer
2  
Note that you need to press Menu to see the Advanced option, it's not one options on the screen. – GAThrawn May 13 '11 at 10:02

To modify the proxy settings in Android 4 and Samsung Galaxy you should do this:

Go to Settings / Wifi. Long-click on your network and select Modify network. Scroll down to Show advanced options which should show you the proxy options.

share|improve this answer
    
The question was about using proxy authentication. The proxy settings in Android don't allow entering authentication details. – thomasrutter Nov 20 '13 at 4:12

Try Proxy Settings, a free app that reveals the Proxy settings button available in most stock ROMs.

share|improve this answer
    
The question was about using proxy authentication. The proxy settings in Android don't allow entering authentication details. – thomasrutter Nov 20 '13 at 4:11

protected by Community Jun 20 '13 at 9:23

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.