Sign up ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I am using HTC Explorer phone, running Android 2.3.5. I use Opera mini and Opera mobile to browse. Whenever I click any YouTube video in the browser to play, automatically the YouTube app opens and starts loading the video but I have a slow connection so I want videos to be played in streaming media player. For any other websites RTSP links it asks me for the app to use.

Earlier it used to ask me for YouTube videos also but now I don't know what settings I have changed. It does not ask now and opens YouTube app. How can I fix this?

share|improve this question
Did u try disabling youtube – sameer Mar 10 '14 at 12:29

5 Answers 5

  1. Go into Settings -> Applications
  2. Search for Youtube
  3. Scroll to the Launch by default section
  4. Tap on Clear defaults
share|improve this answer
Their are no defaults set for the youtube app.The option "clear defaults" is grayed out. – Akash Jul 20 '13 at 17:05

The best way to accomplish this is to use the mobile browser to browse YouTube then when you click on video and it prompts which app to use, click on the browser rather than YouTube app.

[Also this assumes that you have cleared all of the defaults for YouTube and browser.]

As said above, you could always just disable the YouTube app.

share|improve this answer
  • First Download UC Browser
  • Go to YouTube video you want to play via UC browser
  • Since UC Browser have its own Built in Video Player it wont redirect you to youtube app
  • Now if you want to play it with another video player there is option for that on top right corner called 'Play With'
  • Select Video Player and Enjoy :)
share|improve this answer

Here's the answer to your query.

Use Boat Browser Mini.

Its a really great browser, and small like Opera. On it when you will visit YouTube site, a small prompt will come asking whether to open in browser or YouTube app.

Not only this on many site where you have to download a file, Boat gives an option to stream them by choosing open -> any video app that can stream (MX Player).

share|improve this answer

you should try resetting defaults for your browser app from application manager.

go to settings > application manager > click your browser app from app list (which ever browser u r using) > you are in app info now > clear defaults. this might help u.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.