Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

On my HTC Desire SV, a notification says

SIM card is full Delete some messages to make more space.

I've deleted all my messages and it still won't go away. I've clicked on it and it leads me to a page that says

no messages on the SIM card:

under the title that says

SMS messages on SIM card.

so, I guess my real question is how do I get rid of this? how do I access the SIM card to where I can delete photos and/or messages off of it?

share|improve this question

2 Answers 2

This is a problem with your phone, that it only shows the SMS on your phone, not on the SIM. If you go into your SMS application, and check in settings, you should have an option which says something like: Manage SIM SMS. From there, you should be able to delete the SMS in your SIM.
Other option is to insert your SIM in another phone (probably an old phone will have access to your SIMs SMS) and try it from there.
Yet another optio is to try some SMS management application like HandCent or GoSMS which may enable your to erase SMS from the SIM, though I haven't tried these applications, as it's been a long time since I lat used SMS

share|improve this answer
    
I tried your first option and there is not a single SMS in SIM memory. I checked this SIM card in other mobile phone. I think the problem is some thing else. –  Vinit Vikash Jul 25 '13 at 5:12
    
You got me lost here then. Usually the message is because there are some SMS in the SIM, not on the phone. I recall reading some time ago that the message could also be for having the agenda full. Do you store your contacts on the SIM or on the phone, linked with Google account? –  AitorTheRed Jul 25 '13 at 5:44
    
When you checked the SIM in another mobile, does it gives you the same warning message? If no, then this is a problem of your phone/ROM. What Android version do you have? I was googling a bit, and found some russian forum, where you could check (it's risky, be aware) to update your firmware: forum –  AitorTheRed Jul 25 '13 at 5:49
    
I am storing all my contacts into SIM card and the phone is also linked with google account. I was inserted the SIM card in low end Nokia mobile phone and nothing is there in "Inbox", "Sent items" and in "Draft". –  Vinit Vikash Jul 25 '13 at 11:43
    
@ AitorTheRed ...the link which you provided here ...is not readable by me...because in russian language... –  Vinit Vikash Jul 25 '13 at 11:45
  • Switch off your mobile
  • Remove your mobile battery and SIM card
  • Press your power button for 10 seconds
  • Replace your battery and SIM card
  • Switch on your mobile
  • Issue cleared

  • It worked for me :)

share|improve this answer
    
Everywhere on the Web, posting in all caps is the equivalent of shouting. Please don't do it. And knock off the leet-speak while you're at it. –  Al E. Dec 31 '13 at 13:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.