Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a Motorola DROID v1 that is running Froyo (2.2). I've noticed that if my device sleeps for a while, when I wake it up it will not attempt to connect to the wireless AP in my home. When I go to the wireless settings section, I see a note next to the AP entry that says 'disabled'. If I click the entry and select 'connect', it connects right away. It will remain connected until the next longish sleep, when it is again marked as disabled.

Is there any way to prevent this AP entry from being marked as disabled?

share|improve this question
    
Is your wireless network set to broadcast the SSID? I've heard of people having problems when this is hidden (and there is no real benefit to doing so) –  FoleyIsGood Sep 13 '10 at 20:12
    
No, it isn't hidden. The security is set to WPA-PSK. –  JadeMason Sep 13 '10 at 20:57
    
Did you ever find a solution? –  Matt Dec 28 '10 at 12:41
    
No solution yet. –  JadeMason Jan 4 '11 at 4:04
    
We just started seeing a similar issue on a droid 2 global today. For us, it won't connect the first time -- it just reads "disabled" rather than "connected". Using wpa2 psk, SSID is shown, NG mixed mode. I'll post if we solve it soon. –  jay Jan 13 '11 at 22:11
show 2 more comments

1 Answer

Try this - go to SETTINGS > Wireless & Networking > Wi-Fi Settings. In this screen, press the MENU button and then ADVANCED. Click WiFi Sleep Policy and set it to NEVER.

Hopefully, that will retain a connection to the Wi-Fi Access Point.

share|improve this answer
1  
I tried this, but it didn't appear to have an effect. I think the root cause of the issue is that there are areas of my home with very poor WiFi coverage, and after making several attempts to connect, the OS is marking the AP as disabled to prevent further tries. –  JadeMason Mar 9 '11 at 15:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.