Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I've been following these very detailed instructions to take a screenshot on my Motorola Flipside. When I get to the step #10 where I launch ddms.bat I get this error and my phone doesn't show up:

C:\Program Files (x86)\Android\android-sdk-windows\tools>ddms.bat 12:09:01 E/adb: Failed to get the adb version: Cannot run program "adb": CreateProcess error=2, The system cannot find the file specified

(and here I thought the difficulties of taking screenshots on Android were exaggerated)

share|improve this question
add comment

1 Answer

up vote 5 down vote accepted

Try adding adb's folder (platform-tools) to your PATH. The adb executable used to be in the tools folder on versions of the SDK up to v8 IIRC, but it was moved in v9, so ddms.bat is probably looking for it in the wrong spot.

See also this thread on StackOverflow (accepted answer there courtesy one of our mods here) to see if this is in fact the issue.

Edit: If you need it, here's a decent guide for changing your PATH environment variable. It's written for XP but I don't think the process is much different (if at all) for Vista/7. The basic premise is at least the same.

Another edit: It looks like it's the same process according to this guide for Win7.

share|improve this answer
    
copying the adb.exe just crashed it on launch: Problem signature: Problem Event Name: APPCRASH Application Name: adb.exe Application Version: 0.0.0.0 Application Timestamp: 4ced84a4 Fault Module Name: AdbWinApi.dll Fault Module Version: 6.0.6002.18005 Fault Module Timestamp: 49e03824 Exception Code: c0000135 Exception Offset: 0006f04e OS Version: 6.0.6002.2.2.0.256.6 Locale ID: 1033 Additional Information 1: 9d13 Additional Information 2: 1abee00edb3fc1158f9ad6f44f0f6be8 Additional Information 3: 9d13 Additional Information 4: 1abee00edb3fc1158f9ad6f44f0f6be8 –  travis Jan 21 '11 at 17:28
    
@travis: Try adding it to your PATH, then. I'd never tried copying it, to be honest. –  eldarerathis Jan 21 '11 at 17:29
    
Yep was just about to post this :) Gingerbread SDK broke things by moving the location of adb.exe –  Bryan Denny Jan 21 '11 at 17:29
1  
editing my %Path% worked, thanks! –  travis Jan 21 '11 at 17:35
    
It didn't refresh the %Path% globally, so I just did it via the command line before launching the BAT file: C:\Program Files (x86)\Android\android-sdk-windows\tools>SET Path=%Path%;C:\Program Files (x86)\Android\android-sdk-windows\platform-tools then C:\Program Files (x86)\Android\android-sdk-windows\tools>ddms.bat –  travis Jan 21 '11 at 18:41
show 2 more comments

protected by Community May 27 '11 at 18:30

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.