Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have Kaspersky Mobile installed. Today I had to reinstall it after installing a new rom. Now whenever I turn on the phone, I have to enter the kaspersky unlock code, which is different from the sim card lock code. Before I had the lockcode disabled, and I could use the phone without having to enther any code. I would like to disable the lock code, but can't find the option in the Kaspersky app. I've searched in the system settings, but no luck.

Can you tell me where I can set this option?

Phone info: Samsung Galaxy S2 I9100, Android JB 4.2.2, Avatarrom

share|improve this question
1  
OP: What Device? What ROM? What Android version? Three vital questions omitted... –  t0mm13b Aug 4 '13 at 19:06
1  
Are you sure it's even Kaspersky doing that? Lock settings are usually done by Android itself. Have you checked in Settings there? –  Izzy Aug 4 '13 at 19:10
    
@t0mm13b, I updated the question. –  SPRBRN Aug 4 '13 at 19:17
    
@Izzy, I have to enter the kaspersky code, not the simlock code. So that's enough proof that it's the Kaspersky app. –  SPRBRN Aug 4 '13 at 19:17
1  
Hmmm... Try wiping the data/cache from recovery - do a backup before hand in case! –  t0mm13b Aug 4 '13 at 19:19

2 Answers 2

up vote 1 down vote accepted

I think I got it. This is what I did:

  • System settings > Security > Device managers
  • Disable Kaspersky as device manager
  • System settings > Screen lock: swipe (or what you want)
  • Enable Kaspersky as device manager

Now I can unlock the phone with one swipe. I use App Protector to lock certain apps plus system settings with a different code.

NB: the above names (like device manager) may not be 100% accurate as I'm not using an English version of Android...

share|improve this answer
1  
My English Android device calls it a Device Administrator. –  John Aug 6 '13 at 7:25

Go to Settings > Screen lock> None

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.