Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So I finaly got a copy of Windows and installed VMWare on OS X After fidling with driver issues etc. etc. I got the Kies software to recognize the Gallaxy S

After Kies had downloaded the upgrade files and started (an image of the Android raking leaves on the phone screen) this message pops up

"failed to convert to upgrade mode"

Does anyone know what the problem is? and how to get around this?

share|improve this question
If you're on a Mac, then you should be able to run Windows natively in Bootcamp rather than doing it via a virtual machine otherwise see the answers in this previous question on upgrading a Galaxy S without Windows… – GAThrawn Jan 23 '11 at 22:07
Please don't put "tags" in the title field. By virtue of there being an accepted answer everyone will know that this has been resolved. – Al E. Jan 24 '11 at 16:40
up vote 1 down vote accepted

The picture you got on your phone was upgrade mode (also called download mode). The phone disconnects and then tries to reconnect when it goes into this mode. My guess is that the reconnect failed; it happened to me when I tried upgrading through a virtual machine. I suggest borrowing a friend's computer running Windows natively to do the upgrade.

share|improve this answer
Thanks! That solved this problem. – user2376 Jan 24 '11 at 16:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.