Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I came across a how-to guide for running Android 1.7 in a virtual machine (VirtualBox), but 1.7 is old. I haven't been able to find a Android 2.2 or 2.3 image anywhere, does anyone have any ideas on how to virtualize newer Android OS's? Preferably a free virtualization solution like VirtualBox.

Here is the link about virtualizing 1.7:

They send you to here to download Android disk images:

But I can't find anything newer than 1.7, anyone have any ideas?

share|improve this question

migrated from Jan 24 '11 at 15:11

This question came from our site for computer enthusiasts and power users.

Thanks for the tips! I will check out the nightly builds and the SDK – Josh B Dec 14 '10 at 21:06
Regarding legal questions, Android is open source software, so it would be completely legal for you to run it in a VM. It'll be tricky figuring out how, but Google won't be upset with you for it. Good question, +1! – nhinkle Dec 15 '10 at 7:55
You may find this useful:… – Al E. Jan 24 '11 at 21:36

Android-x86 seems to be the most current project, with nightly builds available at

I think the lack of activity one sees isn't so much a licensing/warez problem, it's just that the OS simply doesn't work too well with desktop systems yet, being highly phone & touch-centric. That and there's simply not a lot of interest for it yet.

I don't know if this project has the Google Apps (particularly Market) baked in or not. If not, that's another major piece that significantly reduces the usefulness of this OS.

Finally, there'd be the problem of getting drivers for all the various hardware made available. Considering Android's Linux base, I'm not sure how easy or difficult it is to do.

share|improve this answer

The easiest way of running android and testing android application on x86 machines appears to be using the android virtual machine that comes with the latest SDK.

With reference to a recent question, Huh? JDK not found? (on Windows 7 64-bit) , there may be a problem with the latest android sdk .exe installer. you can try to download the zip version of the installer, then run "sdk manager.exe"

Place to download the SDK:


Note that you need JDK to run the android SDK


And as @afrazier mentioned, android-x86 is a definite option but the lack of drivers make it difficult for most of us to use the OS properly...

share|improve this answer

Here's a link to to Android 2.3 (Froyo) Live CD: It's a small image (53.6 MB), I ran the live CD on VMWare Workstation and it worked like a charm.

share|improve this answer

I think its easier to get arm processor images than it is to get the x86 ones. I've been able to use the android virtual machine that comes with the software development kit.

share|improve this answer

You can also Download the already done Virtual Machine from Bash Blog, they created a Froyo VMWare image...

The Virtual Machine has only 100MB

share|improve this answer
The link seems to be dead. Can you update the link? – Manubhargav Oct 6 '15 at 2:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.