Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Here are two examples: (I'm using the '|' as the cursor)

Example #1:

I want to put the next word in quotes |

type '"' followed by a word and closing quote:

I want to put the next word in quotes" |
I want to put the next word in quotes" f|
I want to put the next word in quotes" fa|
I want to put the next word in quotes" fai|
I want to put the next word in quotes" fail|
I want to put the next word in quotes" fail"|

Desired (and expected):

I want to put the next word in quotes "|

Example #2:

I want a space before the question mark |

type '?' multiple times:

I want a space before the question mark? |
I want a space before the question mark? ?|
I want a space before the question mark? ??|

Desired (and expected):

I want a space before the question mark ?|

I have all the auto-correct options unchecked in my Motorola Flipside's settings:

Motorola Flipside - device keyboard settings

share|improve this question
3  
That's annoying. Some of the soft keyboards do this too, I hate it. I don't want anything I type to ever be changed, because I typo less often than the software screws it up. –  Matthew Read Jan 25 '11 at 23:05
    
@Matthew I know, it's so frustrating :-( –  travis Jan 25 '11 at 23:20
    
I believe the stock keyboard on 2.2 does not do that, type the word, space, quote, and another word, and a quote, and they all works just as you'd expect. I've tried reproducing the problem in Samsung keyboard, HTC's, and Swype, none of them seems to mess up with the spaces around ". –  Lie Ryan Feb 10 '11 at 7:21
    
OK, I'll add the 2.1 tag, good to know. –  travis Feb 10 '11 at 17:11
    
I just tries to type in a user id an the b**dy keyboard caps the first character on «.». You have to backspace and type the «.» again several times to correct. Generaly the 2.3.3 keyboard is pretty good but with this I reactivate and suggest “Smart Keyboard PRO”. — I just hate Programs who think to be more clever then me. Of course they are not. –  Martin Mar 4 '11 at 8:10
add comment

1 Answer

up vote 1 down vote accepted

I installed Vlingo and I switched over to that as the input method and I no longer have the above issues.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.