Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I'm an experienced Android user and recently my Dad picked up a HTC EVO. I set him up with all the Google services and apps like Gmail, Contacts and Calendar. I exported all of his contacts and appointments out of Outlook to CSV and uploaded them to Google so they can sync down to his EVO. Unfortunately when I go to his Google account sync settings, his phone does not show the option to sync his Google Calendar. The exact option I'm talking about is under (from the home screen) Settings -> Accounts & sync -> your Google account. The phone shows Books, Contacts, and Gmail but the option for calendar is missing. Is this the case on all EVO's?

I have a screen capture of my phone (HTC Incredible) that has the option below that I'm talking about. His HTC EVO does not have it for some reason. Is this a Sprint restriction? Any ideas on how to add it?

Any help is greatly appreciated.

Matt

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I'd make sure that he's done something with Calendar through the web interface, such as add a custom calendar, and then try to add the account to the phone again. To do this you need to clear the data for all Google apps -- Accounts and Sync, Gmail, Google Framework Services, etc. -- and then re-add the account.

I don't believe this is EVO-specific, it seems sometimes Google just doesn't correctly link the accounts sometimes (for example, this question has the same problem except for Picasa: "Sync Picasa Web Albums" option not there).

share|improve this answer
2  
You don't have to do a factory reset. See my answer here. Basically clearing all the data from all the Google apps as you suggest brings you back to the initial Account Setup. –  Matt Jan 26 '11 at 22:13
    
Oh great, thanks! I've updated. –  Matthew Read Jan 26 '11 at 22:27
1  
This Matt says thanks to the Matt's on this thread. I'll get back to my Dad and see if it works. Results will be posted. –  Matthew Riley Jan 26 '11 at 22:36
1  
Confirmed: Clearing the data for all Google apps fixed this issue. The calendar is now syncing down to my Dad's EVO. I think the root cause was that he logged into his EVO before he had used Google Calendar web for the first time so there was no data for the service to sync. –  Matthew Riley Jan 31 '11 at 22:14
    
Great, glad it's working. –  Matthew Read Jan 31 '11 at 22:41

I had just read today about this same problem on a Galaxy S but can't find the post. The post claimed that after adding a second Google account the "Sync Calendar" option appear for both account.

share|improve this answer
    
Yes adding second google account made it work. Thank You! –  user3353 Mar 9 '11 at 9:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.