Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Here's a funky issue. I've been using ADB without any problems on 4.2.1 and 4.2.2 on my Nexus 4 (Stock Android and some CM10-based ROMs). When I flashed a CM10.2-based rom (JellyBro, I believe?) a few months ago, I was never able to get ADB to work, so I restored a nandroid of my previous setup. After a while, I decided to flash the stock 4.3 image and see if I still have the problem. I do.

The setup?

  • Phone: Nexus 4
  • Phone OS: Android 4.3 (Factory)
  • Computer OS: Linux Mint 15

Okay, the problem?

  • I cannot use ADB with my N4 on 4.3.
  • I cannot authorize my computer with my device.

What have you tried so far?

  • I just tried to use the default feature. The phone should prompt to authorize my computer, but I never get a prompt. I checked /data/misc/adb/ and the directory was empty.

    • Even so, I decided to click the "Revoke USB debugging authorizations" option in Developer options.
  • I copied ~/.android/adbkey.pub from my Linux box and put its contents in a new file named /data/misc/adb/adb_key on my device.

    • When that didn't work, I rebooted the device.
    • When that didn't work, I disabled/enabled ADB on the device.
    • When that didn't work, I killed adb on my computer, then restarted it.
    • When a-c didn't work, I did them all sequentially before trying again, which also didn't work.
  • Exactly the same as above, but put it in /data/misc/adb/adb_keys intead of adb_key (because XDA and other sites cite both filenames).

  • Clicked the "Revoke USB debugging authorizations" button again. Rebooted the phone, killed ADB on my computer. Still no prompts to authorize.

  • It only removed /data/misc/adb/adb_keys, not adb_key. So I'm pretty sure adb_key is the wrong filename (despite being cited at a frequency on par with the correct name).

  • Update my platform-tools and Android SDK packages. No dice.

    • Can't actually update; I have the most recent version (18.0.1)
  • Remove and reinstall platform-tools. No dice.

  • By the way, my permissions for the adb_keys file are 300. Owner is root. Group is root. Or in other terms:

    ls -l adb_keys
    -rw------- root root
    

Are you sure this is only happening to you on 4.3?

  • Yes. I have no problems after installing any 4.2 rom with recovery, or the 4.2.2 factory image with fastboot.

And it's exactly the same issue with factory 4.3 or a 4.3-based ROM?

  • Yes. Although I've only tried two or three roms, plus the factory image. There may be a magical rom out there somewhere that does work though.

Have you tried any other devices?

  • I tested adb with my girlfriend's 2012 Nexus 7 running 4.3. It had no issues at all.

Any other computers?

  • Unfortunately no. I only have my Linux Mint 15 box.

Okay, so that's basically the gist of it. Does anyone else have any clever ideas? (Or does anyone see where I was an idiot and made a mistake?)

File transfers over MTP also work fine.

Flashing the 20130910 nightly build of PAC-man actually gave me working ADB without the need to authorize my computer at all. This is fortunate, but the original question is still up in the air: Why can't I get it to work on stock?

share|improve this question
    
Just to confirm, you've got the latest version of adb? tools/android in your SDK download doesn't show any updates available? –  derobert Sep 13 '13 at 1:48
    
Indeed; As I mentioned above (although with terrible formatting), I did attempt to update, but already have the latest version. –  dotVezz Sep 17 '13 at 13:18
    
What are the permissions on the USB device, and what does adb devices say? Sometimes different images use different USB IDs. –  derobert Sep 17 '13 at 16:00
add comment

3 Answers

Try to switch the device into PTP mode (under Settings -> Storage -> USB Computer Connection and manually select the connection mode...) and connect to computer. Let it install, switch back to USB mode and plug in again.

Update: XDA tread

share|improve this answer
    
No dice. Thanks though. –  dotVezz Oct 1 '13 at 17:25
add comment

I had the same issue and I solved it by updating to the latest SDK tools using Android SDK Manager. The problem is actually on your adb not on your phone.

share|improve this answer
1  
I my question, I note that I updated my platform-tools package, and also mentioned in comments that I updated to the latest version of the SDK Tools. Thanks for the suggestion though. –  dotVezz Oct 30 '13 at 12:14
    
This worked for me at first and then it stopped working again! I reflashed my phone to a previous build to fix it temporarily! –  thiagolr Oct 31 '13 at 14:41
add comment

Windows 7

To install the Android USB driver on Windows 7 for the first time:

Connect your Android-powered device to your computer's USB port. Right-click on Computer from your desktop or Windows Explorer, and select Manage. Select Devices in the left pane. Locate and expand Other device in the right pane. Right-click the device name (such as Nexus S) and select Update Driver Software. This will launch the Hardware Update Wizard. Select Browse my computer for driver software and click Next. Click Browse and locate the USB driver folder. (The Google USB Driver is located in \extras\google\usb_driver.) Click Next to install the driver.

share|improve this answer
    
I think you're missing the important step of how you got the Google USB Driver onto your hard drive? –  GAThrawn Dec 30 '13 at 11:10
    
The OP also states that they are using Linux not Windows so I'm not sure how this helps them... –  bmdixon Dec 30 '13 at 11:33
    
Additionally, leaving your email in a public space doesn't seem like a particularly good idea. I'll edit your answer to remove the email just so that it isn't immediately visible. –  dotVezz Dec 30 '13 at 13:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.