Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

My home networks says Saved, Secured but when i open internet it says no internet connection

share|improve this question
add comment

3 Answers 3

I would reset the entire connection. Delete it from your phone and then reconnect, reenter the password, an make sure it saves it. You could have the wrong password, it could just be something simple. If this doesn't help, make sure you haven't turned your connections off, restart your phone. If that doesn't help, make sure your internet connection is up and going. Call your service provider or unplug your router and make it reboot itself then check to see if your phone will pick it up again.

share|improve this answer
add comment

First check whether its just the Wi-Fi on your phone or the LAN on your System.

There are many possibilities with the Wi-Fi not working properly.

  1. Either the key is not matched with the key you configured under your modem Wi-Fi password.
  2. Signal might be weak. ( if signal<=10% then some devices Wi-Fi connection is disabled to save power)
  3. In-appropriate configuration of your modem due to which although the connection might be established you might not be able to browse thereby showing no internet connection.

    For this reason Wi-Fi is termed to have very least preference because of heavy loss of Data during the transmission or disturbance.

    Solution:-

  4. If you signal is weak try to get more strength by getting near to you Wi-Fi or having an external hardware that could boost your signal strength.

  5. If the key is not matched then you need to enter the appropriate the password as set by you.
  6. If the connection is not configured then you need to check your manual and Configure the Wi-Fi settings properly and click forget on your old Wi-Fi network to re-configure the network on your device.
share|improve this answer
add comment

Try changing settings to static IP address. Here is a video where you will find out how to do it in ICS 4.0

share|improve this answer
    
While this might help the OP, you could improve your answer by explaining how. –  Niall C. Dec 25 '13 at 22:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.