Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The camera in a Samsung Galaxy SII GT-I9100 shows a black screen. Photos cannot be taken either. However, pressing the shutter does seem to activate the flash sometimes. Even the front cam fails!

I've tried flashing a few custom ROMs (4.3 based Carbon ROM) over recovery. The ROM works, but the camera gives the same result. I even tried to flash an official JellyBean stock ROM for S2 via Odin. Camera still fails.

Logcat (filter level: 'error') shows:-

E/SecCameraHardware( 1839): nativeGetPreview: warning, ESD reset the camera device (6)
E/SecCameraHardware( 1839): FimcV4l2 poll: error 0
E/SecCameraHardware( 1839): nativeGetPreview: warning, ESD reset the camera device (5)
E/SecCameraHardware( 1839): FimcV4l2 poll: error 0
E/SecCameraHardware( 1839): nativeGetPreview: warning, ESD reset the camera device (4)
E/SecCameraHardware( 1839): FimcV4l2 poll: error 0
E/SecCameraHardware( 1839): nativeGetPreview: warning, ESD reset the camera device (3)

The worst I could fear is the camera sensor being busted, but is there any other software level stuff I could possibly try out?

share|improve this question
    
have u solved it in any way? I have the1 same problem with my samsung. Thank you very much – ALEX May 30 at 15:21
    
@ALEX I don't have the device with me anymore; it seems like the camera IC or some part responsible for it was damaged. More of a hardware issue. – Power-Inside May 31 at 8:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.