Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I've just visited the android market website from my work computer and the website is displaying in German. For what it's worth, I have an Ubuntu box and tried in both Firefox and Chrome (both browsers have en_GB as the first language preference followed by en). I suspect the website tries to be clever and uses my IP address instead of the browser's language settings - all PCs at work (no matter which country) are set to a German IP range.

Is there a request parameter I can add to the URL (or something else) that will force the language to English?

share|improve this question

2 Answers 2

up vote 6 down vote accepted

Add the language parameter to the end of the url: https://market.android.com/?hl=en&lr=lang_en

share|improve this answer

Well, after a bit of searching I have found a (strange) workaround.

In the browser language settings add an unsupported language at the bottom of the list (I chose Faroese because I thought the chances of market support were slim) and then restart the browser. At this point the market website will display in English for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.