Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I've got an old HTC Desire with a bitcoin stuck on it. Trying to access "/data/data/de.schildbach.wallet/files" through ADB shell predictably gives me permission denied.

I tried using unrevoked but it says my firmware version is too new.

I've been following the guide to use revolution at "http://androidforums.com/desire-all-things-root/579600-guide-s-off-root-htc-desire-revolutionary-updated.html" and have successfully got S-OFF, but I still can't access files in "data/data/..." through shell. Now HBOOT screen, although being tagged -Revolutionary- and having S-OFF doesn't have the recovery option.

The phone's current details are Android version 2.2.2 Kernal version 2.6.32.15-gf...

The fastboot screen says

-Revolutionary-
BRAVO PVT1 SHIP S-OFF
HBOOT-6.93.1002
MICROP-031d
TOUCH PANEL-SYNW0101
RADIO-5.11.05.27
Aug 10 2010,17:52:18

FASTBOOT

<VOL UP> to previous item
<VOL DOWN> to next item
<POWER> to select item

BOOTLOADER
REBOOT
REBOOT BOOTLOADER
POWER DOWN

I've followed the guide all the way up to point 6, Adding custom recovery. That seemed to go well with the command prompt telling me

C:\Users\Dave\Downloads>fastboot flash recovery recovery-RA_2.0.1.img
  sending 'recovery' (3936 KB)... OKAY [  1.089s]
            writing 'recovery'... OKAY [  1.146s]
finished. total time: 2.235s

I couldn't find the "recovery" option before but have just found it by accidentally selecting bootloader.

What is the safest way now to fully root the phone without risking deleting that "data/data" folder?

Update: From the point I reached in this post I proceeded to create a nandroid backup from BOOTLOADER and copied the *.img to a folder on my PC, then used unyaffs to extract the data from data.img. This worked a treat and I didn't have to fully root my phone to find what I was after.

One minor problem I encountered was that the first attempt at a backup said it was successful, yet gave me 0 byte files. I just had to free up space on my SD card to fix this.

share|improve this question
1  
As you mentioned Revolutionary, have you seen How to root a HTC Desire running official Android 2.3? If that doesn't work for you, please edit your question and state where you're stuck. Mentioning the Android version running on it might also prove useful. –  Izzy Nov 15 '13 at 11:25

1 Answer 1

You can backup data in an app's /data/data/<packagename> folder by using Android's backup function.

adb backup -noapk com.app.packagename

You will now be prompted to 'unlock your device and confirm the backup operation'. The resulting 'backup.ab' file on your computer contains all the app's data in android backup format. Use

adb restore backup.db 

to restore the backup.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.