Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have recently reinstalled Android due to some problems with the SD Card. I decided to keep all my contacts only in Gmail, as a centralized solution to avoid problems in the future. I do not want other SIM or phone contacts to show in the contacts list anymore.

However if I try to uncheck both the SIM and phone contacts and I do check all possible google contacts groups and the option for showing only contacts with a phone number1, no contact is shown at all.

Note: If I show also the phone contacts them the google contacts are shown (and thus I have some duplicates), but removing the phone contacts removes the google contacts too.

How can I prevent this?

The phone is a B63M.

Edit: since people keep asking the same information:

The contacts are perfectly synched and all under the My contacts group. It's not a synchronisation problem. I'm asking why I must select the show phone contacts in order to see any contact at all (from whichever source you like. Even SIM. I cannot show only the SIM contacts without the show phone contacts enabled.)


1 Having or not this option active doesn't change anything. Even if it is not active no contact is shown.


Updated To make things clearer, here are some screenshots of the situation:

Here I have set only the phone contacts (Contatti del telefono in Italian), without google contacts:

Screenshot of contacts App showing the phone contacts and related options

Here I have added the google contacts in the options and they are shown (see red rectangles. Note the number of contacts at the top going from 116 to 156):

Screenshot of contacts App showing the phone and the google contacts and related options

Now, I'd expect that removing the phone contacts I should see only the google contacts (in this case those that above have red rectangles and the other not shown), but this is what I get:

Screenshot of the contacts App not showing any contact and related options saying to show only (and all) google contacts

On the right it just says that there are no contacts to show and that I can add new contacts or import/export from other sources.

What should I do such that this last set of options does show the google contacts?

share|improve this question
    
What phone? Android version? – geffchang Nov 28 '13 at 6:33
    
Are you sure your contacts are synchronized? Are you sure your Google Contacts have a phone in them? (you can check this on gmail) – Shywim Jan 21 '14 at 17:33
    
Go for third-party contacts apps to avoid further problems... – SS-3 Jan 21 '14 at 19:07
1  
@Shywim I've edited the question. Having a phone number is not relevant because even without that option no contact is shown. I just synchronized the contacts and I still have the same problem. I have take some screenshots and I'll soon put them in the question to clarify the situation. – Bakuriu Jan 21 '14 at 20:38
    
@SachinShekhar Which one? I'd expect a good contacts App to: 1) Require less than 0.5 MB of storage, 2) Provide all functionality of the built-in application (without bugs) 3) No useless permissions/features 4) Free 5) No ads. If you know any application that fulfils these requisites then I'd consider your answer. – Bakuriu Jan 21 '14 at 21:35

Go to Contacts > [Sitting Button] > More > Accounts.

Be sure the following are checked:

  1. Background data.

  2. Auto-sync.

share|improve this answer
2  
I'd -1 this answer but unfortunately I don't have enough reputation. As I have already stated in the question contacts are synched. I have both auto-synch and background data active, and I have manually asked for a synchronization multiple times. This is not a problem about synchronisation. It's the App not displaying data that it does have available. – Bakuriu Jan 22 '14 at 10:11

The easiest way is to get the Gmail app from the Play Store.

share|improve this answer
1  
Mistakenly approved the edit. Anyhow, please do not offer offline-support since the future readers may miss a critical info not mentioned here. Ask OP to use comments here for seeking clarifications on your answer and you should try to clarify it only here. Happy answering. :) – Firelord Sep 1 '15 at 8:34

First Type any number(s) select save option then it will show u options blank fields. Along with those fields find the option (it will be on top) or drop down like menu embed depending upon android phone model ...ok

The blank fields to save will change upon selecting type of field u selected.

Second by Default it will be in SIM or phone or ur Email by the time ur checking which else is there the option in that only contacts are saved.

Thirdly For saved contacts goto contacts >options There scroll and find "contacts to display" I hope ur problem must have been solved..

Procedure is correct but options may vary or be located in different ways by different mmanufacturers

share|improve this answer

Finally coming to still other handsets like karbon, celkon, micromax.. soo called china handsets in india. Previously it is found to be they doesnt have any proper sync options.

Example in costlier and top brand handsets contacts sync with g+, FB ...etc and give users suggestions to choose contacts still in social & chat apps were else it is not that much we can expect on unknown handsets.

What i mean to tell u is contacts matching nearly to ur already saved.

one more easiest way if possible to you add contacts directly from gmail in a PC. But login with the email ur using and require after logout, sync in mobile check contacts.

Recently it is seen contacts directly saved to viber, telegram,..etc contacts not Synced with any other app or phone.

share|improve this answer

Contacts/People > Menu > Contacts to Display > select your gmail account to display.

share|improve this answer
3  
I'd -1 this answer but unfortunately I don't have enough reputation. I'm asking this question exactly because what you describe does not work. – Bakuriu Jan 21 '14 at 18:12

protected by Community Feb 3 at 0:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.