Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

My phone received and installed an OTA update this weekend, to Android version 4.3

Now everytime my phone connects to the internet or I go to use the internet, I get this large list of push notifications, of email attachments from my Microsoft Exchange email account, that have never even been downloaded.

I checked the options in the exchange options, and the option to download attachments when connected to wi-fi isn't checked (i've also checked and unchecked it). I also turned off the email notifications for the account, but still get the notifications of the downloaded attachments (even though they are not actually downloading, because you can't even open them).

Screenshot
Screenshot (click to enlarge)

share|improve this question

6 Answers 6

Had same problem. Download manager seems to be the issue if you have that installed. But just click on one of the notifications, you will see App Info. Click on that and then unclick show notifications.

It should go away.

share|improve this answer

Just disable notifications in Play Store.

Open Play Store -> look for the three dot ᐧᐧᐧ menu -> Settings -> Uncheck Notifications

share|improve this answer

This happened to me as well, but seemingly fixed it.

  1. Turn off wi-fi temporarily. Only seems to happen to me while connected to wifi (possibly because my email app settings are set to only download when connected to wifi).

  2. Go to apps list and find an app called "Downloads".

  3. Choose the "Other downloads" tab.

  4. Check the boxes for most/all items and click delete.

  5. Click the down arrow called "Older" and check all remaining items and click delete.

  6. Turn wi-fi back on.

share|improve this answer

I went into the Download Manager app and once it opened went to the right where it says "Other Downloads" and deleted them all and I rebooted the phone and it seemed to work ok. I havent noticed them coming back or any other issues by doing this as of yet.

share|improve this answer

Here's what I did with that same problem.

  1. Settings
  2. More tab
  3. Application manager
  4. Scroll right to all
  5. Select download manager
  6. Force stop, and then clear data and cache
  7. Reboot
share|improve this answer

I turned off the sync and turned it back on and the notifications went away.

share|improve this answer

protected by Community Feb 18 at 12:32

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.