Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Ever since I updated the software on my Galaxy S3 the camera light flashes randomly all day, it also flashes when my alarm goes off.

I cannot find anywhere in my settings how to disable this annoying light. My flash notification is not checked off. Please help!

share|improve this question
add comment

4 Answers 4

S3 users have reported similar issue while receiving calls and alarm going off at AndroidCentral forums here.

The solution posted there is to go to Settings > My Device > Accessibility > Hearing > Flash Notification

Un-check Flash Notification.

Even if the flash notification box is not checked, check it once and un-check it again. It should solve your problem.

share|improve this answer
add comment

Was annoying, but has stopped, by doing the following:

Go to: Settings > My Device > Accessibility> Hearing> Flash notification

Select flash, close out, return and deselect flash.

Working properly now!

share|improve this answer
add comment

This phenomenon could be due to some rogue app that is using the permissions of the camera to take pictures or activating flashlight without your intervention.

Check with some app like F-Secure App Permissions, applying the advanced filter CAMERA, FLASHLIGHT (applying OR operator as shown in the screenshots).

In the resulting list, look for any suspicious app (mainly a game or another app that should not be using those permissions) and uninstall it (you can uninstall apps directly from F-Secure App Permissions by long-tapping its name in the list and tapping Yes in the confirmation message).

Select Advanced filter Applying filter "CAMERA OR FLASHLIGHT" List of filtered apps

share|improve this answer
add comment

I found it was a flashlight app I had downloaded. It had permissions to override various functions. After uninstalling the app, the flashing is gone!

share|improve this answer
add comment

protected by Community Mar 1 at 13:52

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.