Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a problem with syncing with the Google calendar. Although the syncing in most cases does work, for some events it just doesn't sync. I create events on Google Calendar, but they don't show up on the phone. Actually, I create them over iCal, which is also synced to Google Calendar, but that shouldn't matter. I checked and all events are online on Google's servers.

Do you have any idea what could be wrong and how I can force it to sync?

(HTC Desire)

share|improve this question
    
Check in accounts and sync that you have Calendar set to actually sync. if force sync works, that makes me think that it's not syncing any other time. –  Ryan Conrad Feb 17 '11 at 12:26
    
But the thing is that it does sync. I created an event, a minute later it was in the phone calendar. But some events are just not there... –  Ivan Feb 17 '11 at 12:38
1  
are they in a different "calendar", or set to private or something? I have 5 different calendars that all sync to my phone. i haven't noticed any events not showing up as long as they are "my events" in my calendars. –  Ryan Conrad Feb 17 '11 at 14:14
    
I don't have a solution, but I'm seeing some similar issues with calendars I share with my wife. If she enters events in GCal on the web everything is fine, but if she creates an event on her phone, we can both see it on the web, but it doesn't sync properly to my phone. –  Al E. Feb 17 '11 at 14:45
    
@Ivan: What happens if you edit one of these events in GCal (even just open and save)? Will it then sync properly? –  Al E. Feb 17 '11 at 14:45

5 Answers 5

I had similar problem. I had to clear calendar cache - than re-sync worked for me. The cache clear method is very similar like in this answer, but I clear the official Calendar storage:

Go to Settings -> Applications -> Manage applications. In the top of the screen select All. Scrool down to Calendar Storage, then open it, tap to Clear cache button. Re-sync (Google) Calendar. You're done.

Maybe you have no Calendar Storage app, than I sorry, I have HTC Wildfire.

share|improve this answer

Try clearing the calendar's cache (Settings -> Applications -> Manage applications, choose the application, then Clear Data) and then re-sync (how to do that depends on the app).

share|improve this answer

If you have multiple calendars, it would be worth checking that the calendars you expect are enabled on the handset. In Calendar, Menu button -> More -> Calendars -> Menu button -> Add calendars then check all the calendars you want displayed.

share|improve this answer
    
I can't find Menu button -> More -> Calendars -> Menu button -> Add calendars on my 2.3.7 Android. Is this a menu option from a newer Android version? –  1486714871-896-4 Oct 10 '12 at 9:37

I had a similar problem where one of my calendars stopped syncing. (The whole calendar, not just some events.) Toggling the show/hide setting didn't have any effect, but removing and re-adding the calendar fixed the problem.

share|improve this answer

i had the same problem, some events from colledge iCal format just wouldn't sync, first time it happened, I force closed it an turned off my phone and it seemed to work, now it happened for the second time and now I tried what somebody suggested here as well as on the other sites, cleared data from the phone because I have everything backed up on my gmail calendar and it seems to be working... for now...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.