Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I've been trying to get everything set up on my new Nexus 5, and one of those things is getting notifications working properly, both on the phone itself as well as on my Pebble watch. One problem I'm having right now (which I basically bypassed with my previous phone) is getting Light Flow to push notifications to my Pebble. I know that Light Flow is handling notifications because the notification LED and vibrate settings are being used, but despite setting the "Send to Pebble" checkbox for the desired notifications, I'm not getting anything on my watch. I did have it working with my past phone, though.

Before people ask in the comments, yes, I can still get notifications on my watch if they originate from the Pebble app. However, I can't set the Pebble app to a sleep mode like I can with Light Flow. There are also notifications that I can get from Light Flow that I can't get from the Pebble app, for instance low battery warning and lost cell connection that I also want. Also, 3rd party notifications are enabled in Pebble.

Since I know that both Light Flow and Pebble are working independently, why can't I get them to work together?

share|improve this question
1  
The Pebble watch itself has a sleep mode built-in these days, in Settings -> Notifications -> Do Not Disturb Schedule. –  GAThrawn Jan 22 at 18:01
    
@GAThrawn Awesome. That solves the immediate problem, as I can now use the Pebble app to push emails. Does the sleep mode also disable the backlight? –  MBraedley Jan 22 at 18:16

1 Answer 1

up vote 0 down vote accepted

The issue is actually caused by the feature that I wanted to make use of: sleep mode. For some reason, if the option to disable Pebble notifications while in sleep mode, all Pebble notifications are disabled, regardless of sleep state. (The release notes indicate that this was already fixed, but that apparently isn't the case.) Since I can disable notifications at the watch (thanks, @GAThrawn), I have no need for preventing Light Flow from sending notifications to my Pebble while I sleep.

Simply disable the sleep mode check for send to Pebble in Light Flow, and notifications will start flowing.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.