Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I've connected my N1 to my Windows 7, and I don't see it as a USB drive. I don't see any message on the phone that allows me to enable this (in the past, I used to see a notification about the phone being connected, that allowed me to enable it as a USB drive. Now I don't)

What should I do to access the files?

share|improve this question
add comment

1 Answer

Under 'Settings' there should be an option 'Connect to PC'. From here you can change the connection type or get the phone to ask you each time it plugs in. (Apparently this is an HTC Sense specific setting(?) so not as relevant here). edit: an answer here has directions to the USB settings.

If it is still not working after changing the settings it may be worth trying another USB cable. Are you sure the cable is working ok? Does the phone indicate that it is charging when it is plugged in to the PC? The cable needs to be capable of data transfer (some will only supply power for charging). Also, the USB port needs to be USB 2.0, not 1.0 or 1.1

If you are sure the cable is working and the phone is still not recognised this might be a Windows problem perhaps. Try re-installing the device driver by 'uninstalling' the phone in Device Manager (see link below for details):

Info in answer from this post here

share|improve this answer
    
There is no 'Connect to PC under' settings. The cable is charing, so it's working well at least in this regard. –  ripper234 Feb 21 '11 at 9:56
    
Hmm, that could be a Sense specific setting then I guess. –  Martin Feb 21 '11 at 10:25
3  
This post on the Google support forum has some info that may be relevant: google.com/support/forum/p/android/… tl;dr - your USB port needs to be USB 2 (1 or 1.1 only allows charging) and your cable needs to be rated for data transfer (some will only allow charging). Failing that it could be a Windows 7 issue - uninstall the driver from Device Manager then re-connect the phone (better instructions on that link). –  Martin Feb 21 '11 at 11:02
1  
I agree with Martin, sounds like a cable or possibly USB port (either computer or device) issue. –  Matthew Read Feb 21 '11 at 15:01
    
Oh, and rather than Settings -> Connect to PC try looking for Settings -> Applications -> USB settings –  Matthew Read Feb 22 '11 at 18:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.