Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I came across a Google play app that says version 4.0.3 and up required and I have 4.1. So do I have to upgrade because I rather not as my old apps ptobably will not work with 4.3. My question is whether it's a typo and they meant to say 4.3 or is my OS 4.1 good enough?

Phone: S3

share|improve this question
    
They are a bit confusing with their names sometimes. 4.0 is ice cream sandwich, 4.1 is jelly bean 4.2 is jelly bean, 4.3 is... jelly bean again, 4.4 is kitkat. It's a bit weird. They subdivide down again, eg KitKat had 4.4, then a patch making it 4.4.1 then another patch making it 4.4.2. There's no consistencly like the first number changing means a new code name or anything. Generally apps needing 4.0 and up use some feature introduced often Hardware Acceleration. However, some just set their app for that and higher just because really! –  RossC Jan 30 at 15:28

2 Answers 2

Here, you can see the versions: Wikipedia about Android
4.0.x is older than 4.1.x and so on. It's explained here

share|improve this answer

No, as 4.0.3 is Ice Cream Sandwich while 4.3 is Jelly Bean. What you saw was the version number of the application, not the needed version of Android.

I hope this helped!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.