Sign up ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

When I go on a page that's totally in a foreign language the "do you want to translate" option comes up but how do I make Chrome translate a page that has 90% English and a few lines in another language. Is there a button I can install or something because the Google Translate thing doesn't come up when only a few sentences are in another language.

OS: 4.1 S3

share|improve this question
This drives me mad to be honest, I end up copying and pasting from Chrome to Google Translate app when this happens. I'd love to see a workaround to this issue. – RossC Jan 30 '14 at 11:01
Check this ; – Vembu Jul 1 at 17:21

2 Answers 2

In my device(nexus 5) I have Google translate and chrome. if i want translate words→long press →share→translate them. you can try it. :)

ps: Forgot my poor English.

share|improve this answer
This approach saves me three steps :) – Mikhail Nov 15 at 11:11

Follow steps below:

  1. Open Google Chrome.
  2. Go to menu > settings > site settings > Google translate.
  3. There you can configure your settings for translate.

Hope my answer helps.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.