Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a Nexus 5. It is fairly new - I bought it about 2 weeks ago.

I have previously plugged it into my Windows 7 PC and been able to access the files on it.

However, today when I plugged it in, the PC couldn't find it. Some googling and investigation found that the device driver wasn't installed - and then it said that it didn't exist.

I have downloaded the Google USB Driver from the official site. But when I told it to update/install this driver, I was told the driver didn't exist.

The LG Driver installed, but the PC still doesn't "see" the phone to let me use it as a USB.

I don't want a complicated solution. I just want to be able to get my photos off my phone and onto my computer.

share|improve this question
    
The LG driver installed, but the PC still doesn't "see" the phone to let me use it as a USB. –  openidwontworkthrowawayaccount Feb 1 at 9:42
    
LG driver found here: theandroidsoul.com/… –  openidwontworkthrowawayaccount Feb 1 at 9:50
    
Check this link. This solved my issue :) –  Mr_Green Nov 2 at 10:16

2 Answers 2

up vote 8 down vote accepted

Option 1:

  1. Go to device manager in Windows and delete anything having to do with your phone (LG, Google, Android etc)
  2. Plug in your phone, the drivers should install automatically

Option 2: Download Airdroid on your phone....you can transfer files over WiFi

share|improve this answer
    
Device Manager doesn't show ANY phone-related drivers - I can't see anything called LG, Google or Android, despite knowing some of these MUST be installed. I suspect this may be part of the problem. –  openidwontworkthrowawayaccount Feb 2 at 7:01
    
Went with the Airdroid option. Thank you, it let me get the photos I was after. –  openidwontworkthrowawayaccount Feb 2 at 7:03
    
My Nexus 5 was under "Other Devices". I right clicked on it, hit "Uninstall" and then reconnected my phone and it detected it. –  Mitch Jun 28 at 17:09
1  
My Nexus 5 was listed as "Asus Device" in its own category. –  jnnnnn Sep 7 at 12:49
    
To me it was listed as "Acer Device" in its own category. [Windows 8]. –  Mr_Green Nov 2 at 10:07

go to settings then storage click the 3 dots in the top right hand corner click USB computer connection choose one of the 2 options

share|improve this answer
    
I'm not sure why this was downvoted. The accepted answer didn't work for me, but this answer worked great! –  vanmelle Sep 4 at 21:36

protected by Community Jun 21 at 5:54

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.