Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have connected a Samsung Galaxy S i9000 to a Linux machine over the USB cable.

How can I access the disks of the galaxy from the linux machine through this cable (and not through wireless or by opening the cover and removing the sd card).

I cannot find anything under /dev/disk/by-id/ on the linux machine that could be mounted.

Edit: While connected via USB, there is a USB icon on notification bar of the galaxy android device. When I drag the notification bar down, you I see a "USB connection" item. But I cannot do or change anything with it.


The steps from the accepted answer:

1) Go to Settings - Applications - Development and turn USB Debugging to off.

2) Go to Settings - About Phone and switch USB connection to Ask on connection. Maybe mass storage could also work, but in my case there was some samsung app kies still blocking the connection with this setting, so I prefer ask

3) Connect the device to the linux box with the USB cable. The android device brings up a menu, select mass storage

4) There should appear a USB icon on the notification bar of the android device. Drag it down and select mount...

If nothing is mounted on the linux box automatically to /media/ you have to mount manually.

You can watch the syslog on the linux box with this command, type it into a console of a user that has sudo rights before you connect the USB cable:

sudo tail -f /var/log/syslog

Some messages should appear after you connect the cable that help you analyze the situation.

This link is also a good resource: http://androidforums.com/android-lounge/115574-solved-cannot-mount-android-device-via-usb-linux.html

share|improve this question
add comment

1 Answer 1

up vote 5 down vote accepted

Go to Settings -> About phone -> USB Settings and set it to Mass Storage. You may also need to enable or disable Settings -> Applications -> Development -> USB debugging. The drives should be visible to the PC when you connect the device, but you should also have to click the USB notification you mention and tell it to actually mount the storage to PC so that they are accessible. Finally, try looking at this for more info: http://androidforums.com/android-lounge/115574-solved-cannot-mount-android-device-via-usb-linux.html

share|improve this answer
    
I went to Settings --> Applications, but there is no submenu USB Settings. I see the submenus Unknown sources, Manage applications, Running services, Development and Samsung Apps in there. I will keep searching for USB Settings, hoping it is somewhere hidden. –  mit Feb 22 '11 at 18:54
    
You can check in Development as well -- try enabling/disabling USB Debugging and see if it has any effect. If it's enabled, disabling it might actually make the USB Settings menu show up. –  Matthew Read Feb 22 '11 at 19:00
    
Turning on USB Debugging actually helps a bit. I have now a different USB connection item in the notification bar, which can be switched to mount or unmount. When I set it to mount the folder "My Files" on the android device is no longer accessible. But how can I mount anything on the linux machine? /dev/disk/by-id still has no more drives in it. Also /media is empty. –  mit Feb 22 '11 at 19:26
    
Hmm I just searched around a bit and it appears USB Settings might be in Settings -> About phone, can you see if it's there and if so, set it to Mass Storage? –  Matthew Read Feb 22 '11 at 19:33
1  
I could also solve my mounting problems now, I had to go to a different linux box, it seems the usb card on the first box was broken. Now it works. Thank you again, it is good that people like you are around. –  mit Feb 22 '11 at 21:09
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.