Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For a couple of days now I've had error messages when viewing my mail in the Google Mail app. In the beginning the error was displayed when loading mails further down the list.

By now I won't see any mails at all first entry is "Internal error"

Since these issues started the notifications of new mails has stopped working as well and I could not open certain mails (with and without attachments)

How can I get to the bottom of this?

Thanks, seb

share|improve this question
up vote 3 down vote accepted

It sounds like the database is corrupted. I would go to Settings -> Applications -> Manage applications and clear the data for Gmail and Gmail Storage. If that doesn't work, try clearing the data for everything Google (Talk, Google Framework Services, etc.).

share|improve this answer
I thought about doing that, thanks. Done and now I'm waiting for the mails to sync... – seb Feb 23 '11 at 19:35
This is weird. If you're using the wireless network, have you tried WiFi? And vice-versa. More than one WiFi network? Have you tried logging in to your Gmail from the web? – Matthew Read Feb 23 '11 at 20:56
Also note that Gmail 2.3.4 came out today, you may want update. – Matthew Read Feb 23 '11 at 23:27
Hi, I did restart my phone and after that it was immediately available, email notifications as well! – seb Feb 24 '11 at 9:53
Great, glad it's working :) – Matthew Read Feb 24 '11 at 14:21

Glad your problem is resolved. However, to answer the question a little more directly, there are logs where additional information for things such as this often exist. You can download Android System Info from ElectricSheep and you can view the logs here. It's very unfriendly but is sometimes helpful.

share|improve this answer
Thanks, installed that! – seb Feb 24 '11 at 19:23

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.