Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Can't figure out how to change the settings on my Samsung Galaxy S phone to actually have a ringtone when receiving a call.

When receiving a call a voice says "call from 123-456-7890" or "call from Fred". I know how to set the ringtone which has been set..but I don't know how to take the voice off.

So how do I turn off these spoken notifications and get back the ringtone I've set?

share|improve this question
    
sounds like you have some 3rd party application that "announces" the calls. –  Ryan Conrad Feb 25 '11 at 16:45
3  
Also see if there's something in the Accessibility Settings that's rendering this functionality. –  Sparx Feb 25 '11 at 17:23
add comment

7 Answers

On my Droid 2 it's under Settings > Call Settings > Caller ID Readout...then you can set Ring Only, Caller ID then Ring, or Caller ID Repeat. I realize you have a different phone, but I hope this helps.

share|improve this answer
    
I don't have Caller ID Readout on my Droid (2.2.1). Would love to have that option when using a headset. –  TomG Feb 25 '11 at 21:40
    
All I get is the number on my earpiece. But my wife, also using a Droid 2, gets the Caller ID. The only difference I can find is that she got an LG earpiece and I got a Jawbone. –  LeoB Feb 28 '11 at 13:20
add comment

For Galaxy S2 go to Settings -> Language and Input -> Text-to-speech output and turn off Driving Mode. This should turn off both call and messaging readout.

share|improve this answer
1  
This is in the same place on a Galaxy S with Gingerbread –  GAThrawn Sep 5 '11 at 20:02
    
This finally told me where this setting was, seems to be in different places in different phones! –  Keith K Oct 27 '11 at 12:45
add comment

In Epic 4G (imagine same for other Galaxy S handsets):

Settings -> Text-To-Speech -> Speak incoming CallerID

share|improve this answer
add comment

For Galaxy S2, in Settings, Voice input and output, Text-to-speech settings, turn off Driving mode, this should turn off both call and messaging readout.

Actually, you have to go into the driving mode settings and disable the option for incoming call read out. I disabled all of the read out messages for new email etc. I don't want my phone talking to me ever! Turning off driving mode did not work on my new Galaxy s2.

share|improve this answer
add comment

This applies to the AT&T SGS2 (SGHi777). My problem started when I ran the "Voice Command" app. I started the driving mode, but even after I turned it off, it would still read the CID in my ear. After reading all the answers here and trying everything, I still had the problem. I finally tried -Settings->Voice input and output->Text-to-speech settings->Check "Always use my settings". Finally I have peace. Thank you everyone who helped steer me in the right direction.

share|improve this answer
add comment

Go into Settings->Accessibility and uncheck "Talk back".

share|improve this answer
add comment

Okay, I had the same problem.

Go into Settings, then click Voice input and output Next, click Text-to-speech settings, from there you should see something called Driving Mode. If its got a tick next to it, you've found your problem. Untick driving mode and the voice will stop reading out the number.

I accidentally clicked that button a while back, and have spent the past week trying to work out how to put it back.

share|improve this answer
add comment

protected by Community Dec 2 '11 at 23:13

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?