Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I live in a large city and there are random open wifi networks everywhere that allow my Android to connect to their network but won't give internet access because there is a paywall. This is only apparent when you start a browser on the phone. (And is annoying because working mobile 2G/3G access is suppressed in the mean time)

Is there an (automatic) way to stop my phone connecting to a wifi network unless it's password protected ie when I'm at home or at a friend's house?

EDIT: The networks are often named the same eg "BTOpenZone" (but have different IPs so can't be blocked one at a time). There are a wide variety of providers like BTOpenZone. I'd like to block them all, adding exceptions if I ever find a non-paywall connection.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

It shouldn't be connecting to WiFi networks unless you have previously connected to them.

If you go into Settings and view your WiFi networks you should see a list similar to:

WiFi listing

The ones that are listed as 'Not in range' are networks you have connected to previously. If these are the open networks that you no longer want to connect to you can click on each one and click the 'Forget' button that appears.

Your phone should not connect to these networks again (unless you tell it to).

EDIT: After your edit it appears like this question will help.

share|improve this answer
    
As mentioned in the Edit, they will often have the same name but different IP addresses so can't all be blocked at the same time if they're all named BTOpenZone –  Noel Evans Feb 26 at 11:38
    
Wanted to test out Wifi Ruler for a bit before accepting. It's working great. Thanks for your help –  Noel Evans Feb 28 at 10:00

You will be connected auto only when you have connected to that WIFI network and Selected the checkbox auto connect when this network is availabel..You Have to go to WIFI settings and Remove the unwanted networks listed

share|improve this answer
    
As mentioned in the Edit, there are too many to block one at a time –  Noel Evans Feb 26 at 11:37
    
That's not about blocking. Your device will not auto-connect unless you have manually connected before. So this will only be an issue if there's one AP with the same name of another you're normally using. –  Izzy Feb 26 at 11:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.