Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I'm running 2.3-Gingerbread. Calling was working fine over the telephone network. I set up the internet calling feature by adding an account to test the featuire out. Then I removed the account. Every time I dial a number I get this error:

No Internet calling account
There are no Internet calling accounts on this phone. Add one now?

If I click cancel, it doesn't dial using the telephone network it just returns to the home screen.

I've cleared the defaults for the Dialer application but still the problem persists.

Does anyone know how I can prevent this error?

share|improve this question
add comment

5 Answers

up vote 3 down vote accepted

Do you have an app called "Voice Changer" installed? I've read that it can cause this. Also if you have google voice installed, do you have it set to "Never Dial with Google Voice"?

If those are not the cause, do you have any other "Phone Linking" apps or "Sip Dialers" etc, remove them and see if your issue stops.

share|improve this answer
    
Had a SIP app. Disabling it seemed to do the trick. Thanks. –  sickgemini Mar 4 '11 at 1:27
add comment

While I don't have the Nexus S, so can't say for sure, but my guess is that you've accidentally made Internet Calling the default action for dialing a number. Go to settings> applications> manage applications and clear defaults on the Internet calling application, not the dialer.

share|improve this answer
    
Actually running on HTC Magic! Thanks for your suggestion. I tried it but there is no 'Internet calling' application. –  sickgemini Mar 2 '11 at 5:32
add comment

Go to Settings >> Applications >> Manage applications >> All >> Dialer.
Under "Launch by default" press the "Clear defaults" button.

share|improve this answer
add comment

I had Voice Changer installed and the second I uninstalled that it worked. Also go to Settings -> Call and go to the bottom and hit "Only for Internet Calls".

share|improve this answer
add comment

I've had the same problem. Try this: go to Settings; Call; Use Internet Calling; and select the middle option: Only for Internet calls. I haven't encountered the problem since I did this. Good luck!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.