Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I'm using a beta of Cyanogenmod 7 and it seems unlikely they would leave out home and search button functionality. I tried rolling back to the RC and then getting the latest nightly and then wiping the data and cache and then getting the latest RC and nightly. But still, when I press Home or Search, the phone vibrates as if I pressed something but doesn't go home or bring up a search box. Thankfully, "back" still works.

Is the hardware defective??

share|improve this question

2 Answers 2

up vote 4 down vote accepted

If the phone's registering the keypress and vibrating, I don't see how it could be a hardware issue. Flash back to stock and see if it works. Or at least CM6.

share|improve this answer
1  
Agreed. Roll back to your previous stable ROM and see if the buttons still don't work. If not, then you might have a HW problem. –  Bryan Denny Mar 1 '11 at 16:39
    
But CM6 is ugly to me now! –  tooshel Mar 1 '11 at 23:04
    
Okay, I got CM6 but it gave me the "swirl of death" (Cyanogen screen never went away). So I booted into recovery and wiped the cache and data and then CM6 booted. And my buttons worked! And the phone was snappy! So I went to CM7 RC1 and my home button worked. So then I went to the latest CM7 Nightly and my home button worked! I think it was that I needed to wipe. But I lost all my Angry Birds progress!!!! Nooooo. Gotta find it in a backup. I'm asking that now. –  tooshel Mar 2 '11 at 16:26

This means the provisioning got somehow interrupted; in other words, when you just reinstalled the firmware and the wizard was guiding you through the first steps, something interrupted it and it didn't finish. That's why the Home button, the Search button and the Lock Screen don't work.

To fix this, run the following command from a root terminal or from adb shell:

sqlite3 /data/data/com.android.providers.settings/databases/settings.db "INSERT INTO secure (name,value) VALUES ('device_provisioned','1');"

and then reboot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.